[xwiki-devs] Problem building XE

K Konro kkonro at gmail.com
Fri Mar 25 17:09:22 UTC 2011


Hi guys, I have a problem running XE and can't solve it by myself. I have
checked out the source, and did mvn install, and if I understand the
Building documentation correctly this should be enough to run XE (I'm new to
maven). But after the building ends (with status BUILD SUCCESSFUL), I have
no jetty running. Also, near the end of build process such message shows up
4 times:

[WARNING] Cannot include project artifact:
org.xwiki.enterprise:xwiki-enterprise-jetty-hsqldb:pom:3.0-SNAPSHOT; it
doesn't have an associated file or directory.

I also tried to deploy the generated WAR but after opening up the webroot in
browser a hibernate exception shows up about error in configuration file (I
believe it can be related to the above).

Also, when I tried to build XWiki Platform, it also succeeded, but when
trying to quickly deploy app as in instructions (mvn install -Pjettyrun),  I
got a message about missing archetype, with name looking like not-processed
or something:

${xwiki.db.jdbc.groupId}:${xwiki.db.jdbc.artifactId}:jar:${xwiki.db.jdbc.version}

I followed the wiki instructions exactly, what am I doing wrong?



More information about the devs mailing list