[xwiki/xwiki-platform] 640da2: [sonar] Fix java:S1845 - rename fields to avoid ca...
Branch: refs/heads/claude/great-thompson-4UcP7 Home: https://github.com/xwiki/xwiki-platform Commit: 640da2481cfeeb778ddacfacd6fb437a1bcc7d67 https://github.com/xwiki/xwiki-platform/commit/640da2481cfeeb778ddacfacd6fb4... Author: Claude <[email protected]> Date: 2026-05-12 (Tue, 12 May 2026) Changed paths: M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/web/CreateActionRequestHandler.java Log Message: ----------- [sonar] Fix java:S1845 - rename fields to avoid case-only clash with static constants Rename private instance fields `name` → `documentName` and `type` → `documentType` in CreateActionRequestHandler to avoid the SonarQube java:S1845 violation caused by fields differing only by case from static constants NAME and TYPE in the same class. The public API (getName()/getType() methods) is unchanged. https://claude.ai/code/session_01QgmnAv2PrGXoB92BAt514b To unsubscribe from these emails, change your notification settings at https://github.com/xwiki/xwiki-platform/settings/notifications
participants (1)
-
XWiki Notifications