[xwiki/xwiki-platform] d3f019: Fix SonarQube S1845: Rename toXml to toXMLString i...
Branch: refs/heads/claude/magical-faraday-pOYck Home: https://github.com/xwiki/xwiki-platform Commit: d3f019070bdd2f96ec86129a90fe091af2eac142 https://github.com/xwiki/xwiki-platform/commit/d3f019070bdd2f96ec86129a90fe0... Author: Claude <[email protected]> Date: 2026-05-16 (Sat, 16 May 2026) Changed paths: M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/plugin/packaging/Package.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/plugin/packaging/PackageAPI.java Log Message: ----------- Fix SonarQube S1845: Rename toXml to toXMLString in Package to avoid case-only method name clash The Package class had two groups of methods differing only by case: - toXml(XWikiContext) returning a String - toXML(XMLWriter) and toXML(OutputStream, XWikiContext) for streaming This violates SonarQube rule java:S1845, which flags methods whose names differ only in case as they can confuse developers and hide bugs. The fix renames toXml(XWikiContext) to toXMLString(XWikiContext) to make the naming difference explicit. The old toXml method is kept as a @Deprecated wrapper to preserve backward compatibility. PackageAPI is updated to call the new toXMLString method directly. Fixes https://sonarcloud.io/project/issues?issues=AW5-S6tI1Yj5qvzeRnn8,AW5-S6tI1Yj... https://claude.ai/code/session_01Q3VyohR4bFNxpSt5gvDDNN To unsubscribe from these emails, change your notification settings at https://github.com/xwiki/xwiki-platform/settings/notifications
participants (1)
-
XWiki Notifications