[xwiki-devs] Maven-based naming best practices
Hello, Does XWiki have conventions documented regarding * directory layout and naming * groupId name * artifactId name * project name (briefly scanned http://dev.xwiki.org and did not find anything) Regards, Roman -- View this message in context: http://xwiki.475771.n2.nabble.com/Maven-based-naming-best-practices-tp758924... Sent from the XWiki- Dev mailing list archive at Nabble.com.
On 02/21/2014 04:47 PM, coldserenity wrote:
Hello,
Does XWiki have conventions documented regarding * directory layout and naming * groupId name * artifactId name * project name
(briefly scanned http://dev.xwiki.org and did not find anything)
Regards, Roman
If you want to have a project in "xwiki contrib", then these steps (including naming conventions for groupId) might be helpful: http://contrib.xwiki.org/xwiki/bin/view/Main/WebHome Aside of that usually if you have both java code and wiki pages in the extension there is the convention to have the java code in separate subdirectories <projectname>-api and <projectname>-ui (cannot find the docs for that either, however) Cheers, Clemens
Hi, I’ve added our current practices at http://dev.xwiki.org/xwiki/bin/view/Community/DevelopmentPractices#HBuildBes... Thanks -Vincent On 21 Feb 2014 at 16:47:37, coldserenity ([email protected](mailto:[email protected])) wrote:
Hello,
Does XWiki have conventions documented regarding * directory layout and naming * groupId name * artifactId name * project name
(briefly scanned http://dev.xwiki.org and did not find anything)
Regards, Roman
Hi Vincent, Thanks for documenting. I was looking for ideas to use on our own project. I have compiled such conventions based on XWiki structure. I have added proposal document which can be re-used (edited and published officially) by XWiki http://design.xwiki.org/xwiki/bin/view/Proposal/BuildConventions It would be interesting to hear thoughts regarding such conventions. Regards, Roman From: Vincent Massol [mailto:[email protected]] On Behalf Of [email protected] Sent: Sunday, March 02, 2014 19:24 PM To: XWiki Developers Cc: Roman Muntyanu Subject: Re: [xwiki-devs] Maven-based naming best practices Hi, I’ve added our current practices at http://dev.xwiki.org/xwiki/bin/view/Community/DevelopmentPractices#HBuildBes... Thanks -Vincent On 21 Feb 2014 at 16:47:37, coldserenity ([email protected](mailto:[email protected]))<mailto:[email protected](mailto:[email protected]))> wrote:
Hello,
Does XWiki have conventions documented regarding * directory layout and naming * groupId name * artifactId name * project name
(briefly scanned http://dev.xwiki.org and did not find anything)
Regards, Roman
participants (4)
-
Clemens Robbenhaar -
coldserenity -
Roman Muntyanu -
vincent@massol.net