Re: [xwiki-devs] [xwiki-notifications] r29794 - enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements platform/xwiki-applications/trunk/administration/src/main/resources/XWiki
On Jun 28, 2010, at 5:02 PM, jvdrean (SVN) wrote:
Author: jvdrean Date: 2010-06-28 17:02:21 +0200 (Mon, 28 Jun 2010) New Revision: 29794
Modified: enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml Log: [misc] Little refactoring
Modified: enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java =================================================================== --- enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java 2010-06-28 14:48:38 UTC (rev 29793) +++ enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java 2010-06-28 15:02:21 UTC (rev 29794) @@ -36,7 +36,7 @@ @FindBy(id = "page") private WebElement pageInput;
- @FindBy(xpath = "//form/div/input[@type='submit']") + @FindBy(xpath = "//input[@id='createTemplateProvider']")
Almost :) @FindBy(id = 'createTemplateProvider') (since ids are unique) Do we have a naming convention for ids? Thanks -Vincent
private WebElement createButton;
public AdminTemplatesPage()
Modified: platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml =================================================================== --- platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml 2010-06-28 14:48:38 UTC (rev 29793) +++ platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml 2010-06-28 15:02:21 UTC (rev 29794) @@ -34,7 +34,7 @@ <input type="text" id="space" name="space" value="XWiki" size="8"/> <label for="page">$msg.get('admin.templates.createprovider.page')</label> <input type="text" id="page" name="page" value="$msg.get('admin.templates.createprovider.defaultdocname')" class="withTip"'/> - <input type="submit" value="$msg.get('admin.templates.createprovider.create')" class="button"/> + <input id="createTemplateProvider" type="submit" value="$msg.get('admin.templates.createprovider.create')" class="button"/> </div> </form> {{/html}}
On Mon, Jun 28, 2010 at 5:04 PM, Vincent Massol <[email protected]> wrote:
On Jun 28, 2010, at 5:02 PM, jvdrean (SVN) wrote:
Author: jvdrean Date: 2010-06-28 17:02:21 +0200 (Mon, 28 Jun 2010) New Revision: 29794
Modified: enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml Log: [misc] Little refactoring
Modified: enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java =================================================================== --- enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java 2010-06-28 14:48:38 UTC (rev 29793) +++ enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java 2010-06-28 15:02:21 UTC (rev 29794) @@ -36,7 +36,7 @@ @FindBy(id = "page") private WebElement pageInput;
- @FindBy(xpath = "//form/div/input[@type='submit']") + @FindBy(xpath = "//input[@id='createTemplateProvider']")
Almost :)
Fixed.
@FindBy(id = 'createTemplateProvider') (since ids are unique)
Do we have a naming convention for ids?
It seems that we're mixing lowercase with camelCase, we do the same with velocity variable names. I have the feeling that we've been using more camelCase recently for both without having a proper rule.
Thanks -Vincent
private WebElement createButton;
public AdminTemplatesPage()
Modified: platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml =================================================================== --- platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml 2010-06-28 14:48:38 UTC (rev 29793) +++ platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml 2010-06-28 15:02:21 UTC (rev 29794) @@ -34,7 +34,7 @@ <input type="text" id="space" name="space" value="XWiki" size="8"/> <label for="page">$msg.get('admin.templates.createprovider.page')</label> <input type="text" id="page" name="page" value="$msg.get('admin.templates.createprovider.defaultdocname')" class="withTip"'/> - <input type="submit" value="$msg.get('admin.templates.createprovider.create')" class="button"/> + <input id="createTemplateProvider" type="submit" value="$msg.get('admin.templates.createprovider.create')" class="button"/> </div> </form> {{/html}}
devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
Jean-Vincent Drean wrote:
On Mon, Jun 28, 2010 at 5:04 PM, Vincent Massol <[email protected]> wrote:
On Jun 28, 2010, at 5:02 PM, jvdrean (SVN) wrote:
Author: jvdrean Date: 2010-06-28 17:02:21 +0200 (Mon, 28 Jun 2010) New Revision: 29794
Modified: enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml Log: [misc] Little refactoring
Modified: enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java =================================================================== --- enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java 2010-06-28 14:48:38 UTC (rev 29793) +++ enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java 2010-06-28 15:02:21 UTC (rev 29794) @@ -36,7 +36,7 @@ @FindBy(id = "page") private WebElement pageInput;
- @FindBy(xpath = "//form/div/input[@type='submit']") + @FindBy(xpath = "//input[@id='createTemplateProvider']")
Sorry to nitpick but I think @FindBy(id = "createTemplateProvider") is faster. Not critical, change it if you want. Also +1 for somebody making an html id rule. I use an-id-name because that's what I saw everywhere. Caleb
Almost :)
Fixed.
@FindBy(id = 'createTemplateProvider') (since ids are unique)
Do we have a naming convention for ids?
It seems that we're mixing lowercase with camelCase, we do the same with velocity variable names. I have the feeling that we've been using more camelCase recently for both without having a proper rule.
Thanks -Vincent
private WebElement createButton;
public AdminTemplatesPage()
Modified: platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml =================================================================== --- platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml 2010-06-28 14:48:38 UTC (rev 29793) +++ platform/xwiki-applications/trunk/administration/src/main/resources/XWiki/AdminTemplatesSheet.xml 2010-06-28 15:02:21 UTC (rev 29794) @@ -34,7 +34,7 @@ <input type="text" id="space" name="space" value="XWiki" size="8"/> <label for="page">$msg.get('admin.templates.createprovider.page')</label> <input type="text" id="page" name="page" value="$msg.get('admin.templates.createprovider.defaultdocname')" class="withTip"'/> - <input type="submit" value="$msg.get('admin.templates.createprovider.create')" class="button"/> + <input id="createTemplateProvider" type="submit" value="$msg.get('admin.templates.createprovider.create')" class="button"/> </div> </form> {{/html}}
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
participants (3)
-
Caleb James DeLisle -
Jean-Vincent Drean -
Vincent Massol