[xwiki-devs] Name for disabled AttachmentVersioning
Hi, devs. How would you name a special "empty" store class used when some store feature is disabled? (see FakeAttachmentVersioningStore, XWIKI-2275) 1 Void 2 Empty 3 Disabled 4 Dummy 5 Mock 6 else? Vincent Massol wrote:
I'm not sure if "Fake" is the best word to use...
I don't think it's a Fake one. It's an empty implementation that does nothing. so I'd rather call it: VoidAttachmentVersioningStore or EmptyAttachmentVersioningStore.
Also I'd replace the comment like:
+ public void deleteArchive(XWikiAttachment attachment, XWikiContext context, + boolean transaction) throws XWikiException + { + // not needed + }
with:
"// Don't do anything since it's a void implementation."
WDYT? Ok. I'll replace.
-- Artem Melentyev
On Apr 12, 2008, at 5:05 PM, Artem Melentyev wrote:
Hi, devs.
How would you name a special "empty" store class used when some store feature is disabled? (see FakeAttachmentVersioningStore, XWIKI-2275)
1 Void
+2
2 Empty
+1
3 Disabled
-1
4 Dummy
-1
5 Mock
-1
6 else?
Thanks -Vincent
Vincent Massol wrote:
I'm not sure if "Fake" is the best word to use...
I don't think it's a Fake one. It's an empty implementation that does nothing. so I'd rather call it: VoidAttachmentVersioningStore or EmptyAttachmentVersioningStore.
Also I'd replace the comment like:
+ public void deleteArchive(XWikiAttachment attachment, XWikiContext context, + boolean transaction) throws XWikiException + { + // not needed + }
with:
"// Don't do anything since it's a void implementation."
WDYT? Ok. I'll replace.
-- Artem Melentyev _______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
participants (2)
-
Artem Melentyev -
Vincent Massol