Re: [xwiki-devs] [xwiki-notifications] r21865 - in platform/web/trunk/wysiwyg/src/main: java/com/xpn/xwiki/wysiwyg/client java/com/xpn/xwiki/wysiwyg/client/editor java/com/xpn/xwiki/wysiwyg/client/plugin/image/ui java/com/xpn/xwiki/wysiwyg/client/plugin/link/ui java/com/xpn/xwiki/wysiwyg/client/widget/wizard/util java/com/xpn/xwiki/wysiwyg/server resources/com/xpn/xwiki/wysiwyg/client/editor resources/com/xpn/xwiki/wysiwyg/public resources/com/xpn/xwiki/wysiwyg/public/images resources/com/xpn/xwiki/wysiwyg/
Marius Dumitru Florea wrote:
Hi Anca,
+ /** + * Builds a selector from a list of pages of the specified page. + * + * @param editedResource the currently edited resource (page for which editing is done) + */ + public AbstractPageListSelectorWizardStep(ResourceName editedResource) + {
+ super();
Isn't this called by default?
Yes, by default the super constructor with no parameters is called, so this line is not needed. It makes sense to call super only when calling a constructor with parameters.
+ return LinkWizardSteps.WIKIPAGECREATOR.toString();
Since I can't use camelcase on constant names I use an underscore instead to separate words: WIKI_PAGE_CREATOR. I don't know if this is a code style convension but it is surely more readable.
Yes, this is how it should be done. I'll add it on http://dev.xwiki.org/xwiki/bin/view/Community/CodeStyle a bit later. Related, I'd like to change the codestyle to allow two consecutive underscores to better separate chunks of the name, like a kind of prefix: DOC_COMMENT__TAG_ADDED, DOC_COMMENT__TAG_REMOVED... -- Sergiu Dumitriu http://purl.org/net/sergiu/
participants (1)
-
Sergiu Dumitriu