Re: [xwiki-devs] [xwiki-notifications] r9235 - xwiki-platform/core/trunk/xwiki-core/src/main/resources xwiki-platform/skins/trunk/albatross/src/main/resources/albatross xwiki-platform/skins/trunk/toucan/src/main/resources/toucan xwiki-products/xwiki-enterprise/trunk/distribution-test/selenium-tests/src/test/it/com/xpn/xwiki/it/selenium xwiki-products/xwiki-enterprise/trunk/wiki/src/main/resources/Main xwiki-products/xwiki-enterprise/trunk/wiki/src/main/resources/XWiki
jvdrean (SVN) wrote:
Modified: xwiki-platform/core/trunk/xwiki-core/src/main/resources/ApplicationResources.properties =================================================================== --- xwiki-platform/core/trunk/xwiki-core/src/main/resources/ApplicationResources.properties 2008-04-18 10:34:43 UTC (rev 9234) +++ xwiki-platform/core/trunk/xwiki-core/src/main/resources/ApplicationResources.properties 2008-04-18 14:14:39 UTC (rev 9235) @@ -41,6 +41,7 @@ save=Save delete=Delete preview=Preview +copy=Copy login=Log-in logout=Log-out homepage=User Profile @@ -65,6 +66,8 @@ author=Author lastauthor=Last Author filename=Filename +rights=Rights +actions=Actions default=default confirmobjectremove=Are you sure you want to remove this object? confirmdelete=This action is not reversible. Are you sure you want to delete this document?
I second Vincent. There should be no "generic" resources. Even if a piece of text appears in more than one place, each feature/page should be self-contained. In the future each feature might come in its own xar, together with its resources, and ApplicationResources should either disappear or contain core messages only, nothing related to the interface.
Modified: xwiki-platform/skins/trunk/albatross/src/main/resources/albatross/usersandgroups.css
This should be renamed (split?) to something like ajaxTable.css, and the selectors should be not on specific IDs, but to all tables with a specific class (like .ajaxTable)
Added: xwiki-products/xwiki-enterprise/trunk/distribution-test/selenium-tests/src/test/it/com/xpn/xwiki/it/selenium/AllDocsTest.java + /** + * Validate input suggest for Page field. + */ + public void testTableViewSuggestForPage() + { + getSelenium().typeKeys("page", "Treeview"); + // The table is updated via Ajax, we give it the time to make this call + getSelenium().setSpeed("1000"); + assertElementPresent("//td[@class='pagename']/a[text()='Treeview']"); + getSelenium().setSpeed("0"); + }
This test should be done like: - typeKeys - waitForCondition(loading is displayed) - waitForCondition(loading disappears) - assertPresent(Treeview) - assertNotPresent(AllDocs) and maybe delete the filter and assert that AllDocs is there The same for the other filter tests.
+ public void testTableViewSuggestForSpace() + public void testTableViewSuggestForLastAuthor()
+ public void testTableViewCopyAction() + { + getSelenium().typeKeys("page", "treeview");
Shouldn't this have some waiting?
+ assertElementPresent("//td[@class='pagename']/a[text()='Treeview']"); + assertElementPresent("link=Copy"); + clickLinkWithText("Copy");
This already asserts, so the above assertElementPresent("link=Copy") is not needed.
+ setFieldValue("targetdoc", "New.TreeviewCopy"); + getSelenium().click("//input[@value='Copy']"); + open(getUrl("Main", "AllDocs")); + getSelenium().typeKeys("space", "New"); + getSelenium().typeKeys("page", "treeviewcopy"); + assertElementPresent("//td[@class='pagename']/a[text()='TreeviewCopy']"); + } +
-- Sergiu Dumitriu http://purl.org/net/sergiu/
participants (1)
-
Sergiu Dumitriu