[xwiki-devs] [Proposal] Supporting symbols/emoticons
Hi devs, I'd like to propose 3 things: 1) Add support for symbols/emoticons using our new system in XWiki Syntax 2.1, i.e. image:symbol:<symbol name> Another possibility is: image:icon:<icon name> ex: image:symbol:success (for the success symbol) 2) Use the existing silk icon library and be able to reference all icons using their file names as the symbol name. For ex, image:symbol:thumb_up 3) Modify the Box macro to accept a ResourceReference as its image parameter so that all valid image resource references can be specified (including the new symbol/icon scheme). WDYT? This will solve the emoticon/symbol need + the generic way of adding a box with any symbol. Open questions: A) Do we need to handle icon size? If so, how? (answer: with an image parameter) B) Do we want to expose all silk icons? What if we use another library later on, will we be able to support all existing silk symbols? Thus, do we need to pick a subset and settle on names independent from the underlying library? For A) IMO we don't need it now and we can always use an image param later on if need be. For B) I'm tempted to think that a set of well-known symbols independent from the underlying library is better (but more work since we need to define that set and the names). Thanks -Vincent
On 10/19/2010 07:57 PM, Vincent Massol wrote:
Hi devs,
I'd like to propose 3 things:
1) Add support for symbols/emoticons using our new system in XWiki Syntax 2.1, i.e.
image:symbol:<symbol name>
Another possibility is: image:icon:<icon name>
+1 for icon scheme
ex: image:symbol:success (for the success symbol)
2) Use the existing silk icon library and be able to reference all icons using their file names as the symbol name.
I'm -0 for file name. As you say below, I think generic names independent from the underlying icon library are better.
For ex, image:symbol:thumb_up
3) Modify the Box macro to accept a ResourceReference as its image parameter so that all valid image resource references can be specified (including the new symbol/icon scheme).
+1
WDYT?
This will solve the emoticon/symbol need + the generic way of adding a box with any symbol.
Open questions: A) Do we need to handle icon size? If so, how? (answer: with an image parameter) B) Do we want to expose all silk icons? What if we use another library later on, will we be able to support all existing silk symbols? Thus, do we need to pick a subset and settle on names independent from the underlying library?
For A) IMO we don't need it now and we can always use an image param later on if need be. For B) I'm tempted to think that a set of well-known symbols independent from the underlying library is better (but more work since we need to define that set and the names).
+1 Thanks, Marius
Thanks -Vincent
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
On Oct 19, 2010, at 10:22 PM, Marius Dumitru Florea wrote:
On 10/19/2010 07:57 PM, Vincent Massol wrote:
Hi devs,
I'd like to propose 3 things:
1) Add support for symbols/emoticons using our new system in XWiki Syntax 2.1, i.e.
image:symbol:<symbol name>
Another possibility is: image:icon:<icon name>
+1 for icon scheme
ex: image:symbol:success (for the success symbol)
2) Use the existing silk icon library and be able to reference all icons using their file names as the symbol name.
I'm -0 for file name. As you say below, I think generic names independent from the underlying icon library are better.
Just to be clear: when I said file name I meant file name without the extension of course. Thanks -Vincent
For ex, image:symbol:thumb_up
3) Modify the Box macro to accept a ResourceReference as its image parameter so that all valid image resource references can be specified (including the new symbol/icon scheme).
+1
WDYT?
This will solve the emoticon/symbol need + the generic way of adding a box with any symbol.
Open questions: A) Do we need to handle icon size? If so, how? (answer: with an image parameter) B) Do we want to expose all silk icons? What if we use another library later on, will we be able to support all existing silk symbols? Thus, do we need to pick a subset and settle on names independent from the underlying library?
For A) IMO we don't need it now and we can always use an image param later on if need be. For B) I'm tempted to think that a set of well-known symbols independent from the underlying library is better (but more work since we need to define that set and the names).
+1
Thanks, Marius
Thanks -Vincent
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
On Tue, Oct 19, 2010 at 18:57, Vincent Massol <[email protected]> wrote:
Hi devs,
I'd like to propose 3 things:
1) Add support for symbols/emoticons using our new system in XWiki Syntax 2.1, i.e.
image:symbol:<symbol name>
Another possibility is: image:icon:<icon name>
+1 for icon
ex: image:symbol:success (for the success symbol)
2) Use the existing silk icon library and be able to reference all icons using their file names as the symbol name.
For ex, image:symbol:thumb_up
3) Modify the Box macro to accept a ResourceReference as its image parameter so that all valid image resource references can be specified (including the new symbol/icon scheme).
+1
WDYT?
This will solve the emoticon/symbol need + the generic way of adding a box with any symbol.
Open questions: A) Do we need to handle icon size? If so, how? (answer: with an image parameter) B) Do we want to expose all silk icons? What if we use another library later on, will we be able to support all existing silk symbols? Thus, do we need to pick a subset and settle on names independent from the underlying library?
For A) IMO we don't need it now and we can always use an image param later on if need be.
In a case of a list of well known icon you find find in many places i think it's better to always download the same and not resize it server side, that way it will be in the browser cache most of the time. And you can still resize it client side.
For B) I'm tempted to think that a set of well-known symbols independent from the underlying library is better (but more work since we need to define that set and the names).
Another possibility is to have image:silk:somesilkifilename.
Thanks -Vincent
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
-- Thomas Mortagne
On Oct 20, 2010, at 10:07 AM, Thomas Mortagne wrote:
On Tue, Oct 19, 2010 at 18:57, Vincent Massol <[email protected]> wrote:
Hi devs,
I'd like to propose 3 things:
1) Add support for symbols/emoticons using our new system in XWiki Syntax 2.1, i.e.
image:symbol:<symbol name>
Another possibility is: image:icon:<icon name>
+1 for icon
ex: image:symbol:success (for the success symbol)
2) Use the existing silk icon library and be able to reference all icons using their file names as the symbol name.
For ex, image:symbol:thumb_up
3) Modify the Box macro to accept a ResourceReference as its image parameter so that all valid image resource references can be specified (including the new symbol/icon scheme).
+1
WDYT?
This will solve the emoticon/symbol need + the generic way of adding a box with any symbol.
Open questions: A) Do we need to handle icon size? If so, how? (answer: with an image parameter) B) Do we want to expose all silk icons? What if we use another library later on, will we be able to support all existing silk symbols? Thus, do we need to pick a subset and settle on names independent from the underlying library?
For A) IMO we don't need it now and we can always use an image param later on if need be.
In a case of a list of well known icon you find find in many places i think it's better to always download the same and not resize it server side, that way it will be in the browser cache most of the time. And you can still resize it client side.
For B) I'm tempted to think that a set of well-known symbols independent from the underlying library is better (but more work since we need to define that set and the names).
Another possibility is to have image:silk:somesilkifilename.
I thought about this too but I didn't like it too much since it means silk becomes an "API" and we cannot remove it as otherwise we'll break people's pages. Thanks -Vincent
On Tue, Oct 19, 2010 at 6:57 PM, Vincent Massol <[email protected]> wrote:
Hi devs,
I'd like to propose 3 things:
1) Add support for symbols/emoticons using our new system in XWiki Syntax 2.1, i.e.
image:symbol:<symbol name>
Another possibility is: image:icon:<icon name>
ex: image:symbol:success (for the success symbol)
+1 for image:icon
2) Use the existing silk icon library and be able to reference all icons using their file names as the symbol name.
For ex, image:symbol:thumb_up
+0, we already rely on this library a lot and I'm not sure there are serious alternatives (ie. open source libs with that much 16x16px icons). It feels a bit hackish to have a long term dependency on the silk naming scheme but I have the feeling that it's becoming a de facto standard for web icons.
3) Modify the Box macro to accept a ResourceReference as its image parameter so that all valid image resource references can be specified (including the new symbol/icon scheme).
+1
WDYT?
This will solve the emoticon/symbol need + the generic way of adding a box with any symbol.
Open questions: A) Do we need to handle icon size? If so, how? (answer: with an image parameter)
Not needed imho: - icons are pixel art and are likely to look very bad when resized - we can do it with generic (%%) parameters right ?
B) Do we want to expose all silk icons? What if we use another library later on, will we be able to support all existing silk symbols? Thus, do we need to pick a subset and settle on names independent from the underlying library?
Same as above.
For A) IMO we don't need it now and we can always use an image param later on if need be. For B) I'm tempted to think that a set of well-known symbols independent from the underlying library is better (but more work since we need to define that set and the names).
If there was an initiative like the freedesktop icon naming scheme (http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.ht...) for the web I'd indeed give my +1 to use it. But AFAIK there's none for the moment, we could start one and try to gather multiple OSS icons set and build a subset ... but it seems like a lot of work for our needs. Thanks, JV.
On 10/19/2010 06:57 PM, Vincent Massol wrote:
Hi devs,
I'd like to propose 3 things:
1) Add support for symbols/emoticons using our new system in XWiki Syntax 2.1, i.e.
image:symbol:<symbol name>
Another possibility is: image:icon:<icon name>
ex: image:symbol:success (for the success symbol)
+1 for icon.
2) Use the existing silk icon library and be able to reference all icons using their file names as the symbol name.
For ex, image:symbol:thumb_up
+0, -1 for hard-coding silk. See my other mail about IconTheme.
3) Modify the Box macro to accept a ResourceReference as its image parameter so that all valid image resource references can be specified (including the new symbol/icon scheme).
+1
WDYT?
This will solve the emoticon/symbol need + the generic way of adding a box with any symbol.
Open questions: A) Do we need to handle icon size? If so, how? (answer: with an image parameter)
Not at the moment. Silk only comes in one size, and pixel art does not scale well.
B) Do we want to expose all silk icons? What if we use another library later on, will we be able to support all existing silk symbols? Thus, do we need to pick a subset and settle on names independent from the underlying library?
I think it would be better to allow all icon names, with no guarantee of availability. On top of that, we should define a set of standard names that SHOULD be present in any icon theme.
For A) IMO we don't need it now and we can always use an image param later on if need be. For B) I'm tempted to think that a set of well-known symbols independent from the underlying library is better (but more work since we need to define that set and the names).
-- Sergiu Dumitriu http://purl.org/net/sergiu/
On Oct 21, 2010, at 12:48 AM, Sergiu Dumitriu wrote:
On 10/19/2010 06:57 PM, Vincent Massol wrote:
Hi devs,
I'd like to propose 3 things:
1) Add support for symbols/emoticons using our new system in XWiki Syntax 2.1, i.e.
image:symbol:<symbol name>
Another possibility is: image:icon:<icon name>
ex: image:symbol:success (for the success symbol)
+1 for icon.
2) Use the existing silk icon library and be able to reference all icons using their file names as the symbol name.
For ex, image:symbol:thumb_up
+0, -1 for hard-coding silk. See my other mail about IconTheme.
3) Modify the Box macro to accept a ResourceReference as its image parameter so that all valid image resource references can be specified (including the new symbol/icon scheme).
+1
WDYT?
This will solve the emoticon/symbol need + the generic way of adding a box with any symbol.
Open questions: A) Do we need to handle icon size? If so, how? (answer: with an image parameter)
Not at the moment. Silk only comes in one size, and pixel art does not scale well.
B) Do we want to expose all silk icons? What if we use another library later on, will we be able to support all existing silk symbols? Thus, do we need to pick a subset and settle on names independent from the underlying library?
I think it would be better to allow all icon names, with no guarantee of availability. On top of that, we should define a set of standard names that SHOULD be present in any icon theme.
Sounds good to me. Thanks -Vincent
For A) IMO we don't need it now and we can always use an image param later on if need be. For B) I'm tempted to think that a set of well-known symbols independent from the underlying library is better (but more work since we need to define that set and the names).
participants (5)
-
Jean-Vincent Drean -
Marius Dumitru Florea -
Sergiu Dumitriu -
Thomas Mortagne -
Vincent Massol