Hi Sergiu, On Mon, Oct 27, 2008 at 7:24 PM, Sergiu Dumitriu <[email protected]> wrote:
asiri (SVN) wrote:
Author: asiri Date: 2008-10-27 13:49:42 +0100 (Mon, 27 Oct 2008) New Revision: 13849
Modified: sandbox/xwiki-application-officeimporter/pom.xml sandbox/xwiki-plugin-officeimporter/pom.xml Log: Changing the name of the officeimporter plugin & application to make more sense.
Asiri, the description of the field should not duplicate the name.
- The artifactId should be lowercase, no space, and have a specific format (like xwiki-plugin-alexa); this is an identifier intended for machines, to be able to identify and locate the artifact. - The name should be like a breadcrumb, from general to specific, human readable, separated by dashes (like XWiki Platform - Plugins - Alexa); this is a human readable identifier (name) of the project, intended for humans to quickly see what module this is. - The description should be prose, describing what the module does. It is intended to describe the purpose of the module.
I know that most of the modules simply use the name as the description, but that does not add any useful information, thus it is wrong.
Yes, I agree. I knew it's wrong but since other modules are following that practise (and since it seems quite easy ...), I thought to change this one too. Will change it mean something. Thanks a lot, I really appreciate your comments :) - Asiri
See http://maven.apache.org/pom.html#More_Project_Information and http://maven.apache.org/ref/current/maven-model/maven.html#class_project
- <description>import office documents such as MS word to xwiki page</description> + <description>XWiki Platform - Applications - Office Importer</description>
-- Sergiu Dumitriu http://purl.org/net/sergiu/ _______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs