Yes, done. Thanks, JV. On Mon, Jun 28, 2010 at 4:53 PM, Vincent Massol <[email protected]> wrote:
On Jun 28, 2010, at 4:47 PM, jvdrean (SVN) wrote:
Author: jvdrean Date: 2010-06-28 16:47:46 +0200 (Mon, 28 Jun 2010) New Revision: 29792
Modified: enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java Log: [misc] Updated test after modifications in the admin app
Modified: enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java =================================================================== --- enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java 2010-06-28 14:23:42 UTC (rev 29791) +++ enterprise/trunk/distribution-test/ui-tests/src/test/it/org/xwiki/it/ui/administration/elements/AdminTemplatesPage.java 2010-06-28 14:47:46 UTC (rev 29792) @@ -36,7 +36,7 @@ @FindBy(id = "page") private WebElement pageInput;
- @FindBy(xpath = "//form/input[@type='submit']") + @FindBy(xpath = "//form/div/input[@type='submit']")
Would be better to use an id or name IMO (would make it more deterministic + less maintenance).
Thanks -Vincent
private WebElement createButton;
public AdminTemplatesPage()
devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs