On 02/22/2010 03:35 PM, Caleb James DeLisle wrote:
Sergiu Dumitriu wrote:
On 02/22/2010 01:10 PM, Vincent Massol wrote:
On Feb 22, 2010, at 12:37 PM, cjdelisle (SVN) wrote:
Author: cjdelisle Date: 2010-02-22 12:37:45 +0100 (Mon, 22 Feb 2010) New Revision: 27203
Modified: platform/core/trunk/xwiki-core/src/main/resources/ApplicationResources.properties Log: XAADMINISTRATION-112: Allow applications to bring configuration forms into the administration app without modifying it. - Added translation keys.
Modified: platform/core/trunk/xwiki-core/src/main/resources/ApplicationResources.properties =================================================================== --- platform/core/trunk/xwiki-core/src/main/resources/ApplicationResources.properties 2010-02-22 11:15:45 UTC (rev 27202) +++ platform/core/trunk/xwiki-core/src/main/resources/ApplicationResources.properties 2010-02-22 11:37:45 UTC (rev 27203) @@ -2522,3 +2522,13 @@ XWiki.Registration.passwordMismatch=Your passwords aren't the same. XWiki.Registration.invalidEmail=Please give a valid email address. XWiki.Registration.fieldOkay=Ok. + +# XWiki.Configurable (Administration application) +XWiki.Configurable.noPermissionThisApplication=You don't have permission to configure this application. +XWiki.Configurable.applicationAuthorNoAdmin=This configuration cannot be displayed because it was last edited by [[{0}]] who doesn't have permission to edit this page. +XWiki.Configurable.cannotLockNoJavascript=This document cannot be locked for editing because Javascript is turned off, for page editing safety, please enable Javascript. +XWiki.Configurable.configurationClassNonexistant=No class found by the name {0}, can't display configuration. +XWiki.Configurable.noObjectOfConfigurationClassFound=No object of class: {0} found in document {1}, can't display configuration. +XWiki.Configurable.sectionIconNoAccess=(No Access) +XWiki.Configurable.sectionIconNoAccessTooltip=You don't have permission to configure this section. +XWiki.Configurable.noViewAccessSomeApplications=Some sections may not be displayed because you do not have view access to some configurable applications including: {0} Shouldn't we have a naming convention for application resource keys?
These are not application resource keys, these are standard class field translations. They MUST have the name<Class.Name>.classProperty.
Actually in this case they are not class fields, they are mainly error messages which are shown by the code in XWiki.Configurable
OK, then they should indeed be renamed. xe.admin.configuration.someKey or xe.configuration.someKey
Something like: XWiki.<Application name>.key or XWiki.<Application name>.subdomain.key or Application.<Application name>.subdomain.key
-- Sergiu Dumitriu http://purl.org/net/sergiu/