The problem is that boolean fields also have -1 as a possible value, which means "not specified". So there will be a problem with this, since we can't tell what 'not specified' should be, true or false. On 7/30/07, Erin Schnabel <[email protected]> wrote:
On 7/30/07, Thomas Mortagne <[email protected]> wrote:
Hi XWikiers,
In BaseClass there is possibility to add Boolean type field with "addBooleanField". In XwikiDocument (and then in BaseCollection), we use "getIntValue" and "setIntValue" to retrieve or set the value with 0=false and 1=true. It's very simple but I think a "get/setBooleanValue" that do the conversion would be much more readable and avoid developper to search how boolean values are really stored.
Regards, Thomas Mortagne
Agreed. Every time I use a Boolean value, I have to remember this. I don't do it so often that it's ingrained.. :-P
Sergiu -- http://purl.org/net/sergiu