12 Feb
2013
12 Feb
'13
11:03 a.m.
Hi, I'd like to propose to use the following naming conventions for the extensions from commons/rendering/platform that are exposed on e.x.o: - "API" suffix for api modules. e.g. "Text API" , "Velocity API" instead of currently "Text Module", "Velocity Module", etc - "Application" suffix for ui modules, e.g. "Wiki Manager Application", "Logging Application", "IRC Bot Application", etc - "Macro" suffix, e.g. "JIRA Macro", etc Technically this means using the following in pom.xml: <properties> <!-- Name to display by the Extension Manager --> <xwiki.extension.name>Wiki Component API</xwiki.extension.name> </properties> WDYT? Thanks -Vincent