On 10/29/2009 12:16 AM, Andreas Schaefer wrote:
Hi
Based on this JIRA report:
http://jira.xwiki.org/jira/browse/XWIKI-4430
it would be necessary to create a new set of methods just to be able to pass an additional parameter to the calls. Because this makes it harder and harder to deal with Plugin I would suggest to use a Parameter Container which could contain:
- Feed Type (Blog, Web, etc) - Type (Query, List or Feed )
- List or - Query, Count and Start or - Feed
- Metadata - Object Class Name - Output Type (RSS, Atom etc)
Then we would only need 2 major methods: - SyncdFeed getFeed( FeedParams ) - String getFeedOutput( FeedParams )
This is what I came up so far (without the Feed Type): [snip] What do you think?
Well, using a class for passing many parameters is most of the times a good idea, so +1. -- Sergiu Dumitriu http://purl.org/net/sergiu/