Vincent Massol wrote:
On Jan 5, 2009, at 1:00 PM, fmancinelli (SVN) wrote:
Author: fmancinelli Date: 2009-01-05 13:00:42 +0100 (Mon, 05 Jan 2009) New Revision: 15058
Added: sandbox/xwiki-core-rest/src/main/java/org/xwiki/rest/internal/ sandbox/xwiki-core-rest/src/main/java/org/xwiki/rest/internal/ PageRepresenter_TEXT_PLAIN.java sandbox/xwiki-core-rest/src/main/java/org/xwiki/rest/internal/ PageRepresenter_TEXT_XML.java
I don't think this follows the Java coding conventions for Java class Names...
Yes, I think you're right. I wrote them this way in order to better highlight the content type as it is defined in Restlet's MediaType.
IMO would be better named:
PlainTextPagePresenter XMLTextPagePresenter
Maybe TextPlainPageRepresenter TextXmlPageRepresenter ApplicationPdfPageRepresenter etc. i.e., use the "camel-caseified"-with-special-characters-removed actual mediatype as a prefix? -Fabio