5 +1s, 0 -1s. Done and pushed in master. Thanks, Eduard On Mon, Oct 3, 2011 at 7:58 PM, Sergiu Dumitriu <[email protected]> wrote:
On 10/02/2011 07:15 PM, Eduard Moraru wrote:
Hi devs,
Since starting to develop the workspaces feature, under the Wiki3.0 project, I`ve used internally the name "Workspace Manager" (providing the script service "$services.workspaceManager") by following the naming scheme used by the Wiki Manager plugin. When the code was moved into the platform, I`ve named the top maven artefact "xwiki-platform-workspace-manager" and the java package "org.xwiki.workspacemanager".
Recently, Vincent proposed [1][2](see arguments) to drop the "-manager" suffix, thus, the following changes would occur: - "$services.workspace" instead of "$services.workspaceManager" - "org.xwiki.workspace" instead of "org.xwiki.workspacemanager" - "xwiki-platform-workspace" instead of "xwiki-platform-workspace-manager" - "Workspace Feature" instead of "Workspace Manager Feature"
Since it's a new module, there are no problems with backward compatibility so the changes can be applied with some minor refactorings of the velocity code using the service.
I did not know about this naming policy, so I`d like your opinion/vote on whether to apply the proposed changes and enforce this policy in the future as well.
Here's my +1.
+1. This should be done ASAP since it blocks the 3.2RC1 release.
Thanks, Eduard
References: ----------------- [1]
https://github.com/xwiki/xwiki-platform/commit/8c1cc0bc73249eee20159dc3e540e...
[2]
https://github.com/xwiki/xwiki-platform/commit/8c1cc0bc73249eee20159dc3e540e...
-- Sergiu Dumitriu http://purl.org/net/sergiu/ _______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs