30 Jul
2007
30 Jul
'07
5:33 p.m.
On 7/30/07, Thomas Mortagne <[email protected]> wrote:
Hi XWikiers,
In BaseClass there is possibility to add Boolean type field with "addBooleanField". In XwikiDocument (and then in BaseCollection), we use "getIntValue" and "setIntValue" to retrieve or set the value with 0=false and 1=true. It's very simple but I think a "get/setBooleanValue" that do the conversion would be much more readable and avoid developper to search how boolean values are really stored.
Regards, Thomas Mortagne
Agreed. Every time I use a Boolean value, I have to remember this. I don't do it so often that it's ingrained.. :-P -- 'Waste of a good apple' -Samwise Gamgee