31 Jul
2008
31 Jul
'08
2:10 p.m.
+1 for 1) because of readability. Vincent Massol wrote:
Hi,
Right now wikimodel implements the following syntax for xwiki macros:
1)
{{macro param1="value1" param2="value2"}}content{{/macro}} {{macro param1=value1 param2=value2}}content{{/macro}}
This is different from the original proposal of:
2)
{{macro:param1="value1"|param2="value2"}}content{{/macro}}
Notes: * I think 1) is cleaner and easier to read * There's no default param in 1) so you don't write something like: {{include:Main.WebHome}}. You have to write: {{include document=Main.WebHome}} * 2) is the same as the current syntax
Which do we want?
-- Artem Melentyev