Hi, In the ratings component I would use "rating" instead of "rate" For example setRating instead of rate removeRating instead of removeRate getRatings instead of getRates etc.. While I see how we handle comments and ratings separately I don't see how it's possible to have a merged rating/comment system. Suppose I want to show ------- * * * Rating by ludovic I like this document a lot. ------- How do we handle this in the current API ? A possible solution without adding comment text inside the rating or without having the rating extend comment, would be to have the "comment" being a comment of the "rating" object. So the container would be the rating. Ludovic [email protected] wrote:
Hi devs,
Due to the fact that we have to extend the platform features, a proposal would be to extend the current comment feature, and add 2 new ones: annotations and ratings. Here are the design proposals for comments and ratings:
http://dev.xwiki.org/xwiki/bin/view/Design/RatingSystem http://dev.xwiki.org/xwiki/bin/view/Design/NewCommentsPlugin
You can review them and give feedbacks.
Thank you,
Raluca.
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
-- Ludovic Dubost Blog: http://blog.ludovic.org/ XWiki: http://www.xwiki.com Skype: ldubost GTalk: ldubost