+1 Caleb On 10/07/2010 05:44 AM, Vincent Massol wrote:
Actually DocumentReference already exists so it's better to find a different naming.
After long thinking I'm proposing: - ResourceReference - DocumentResourceReference - InterWikiResourceReference
So from the Listener interface POV we will have:
onImage(ResourceReference reference...) beingLink(ResourceReference reference...) endLink((ResourceReference reference...)
Note: I've transformed this into a VOTE since it's an important API change.
+1 from me
Thanks -Vincent
PS: I would have liked to reuse the URI class but the standard JDK URI is not good enough for us
On Oct 6, 2010, at 6:11 PM, Vincent Massol wrote:
Hi,
This is a technical refactoring but I'm posting it here since it means changing our rendering API quite significantly.
Basically we currently have 2 notions: Image and Link. I'd like to make them one (called Reference) since we need/want to handle similarly and this would remove lots of duplicated code.
Since we've already broken quite a lot of Rendering APIs in XE 2.5M1/M2 I feel it's a good time to be brave and go the full monty... ;)
I've started the work already but wanted to keep you posted in case someone disagrees.
For the record this is about implementing: - http://jira.xwiki.org/jira/browse/XWIKI-5549 - http://jira.xwiki.org/jira/browse/XWIKI-5554
Thanks -Vincent
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs