Vincent Massol wrote:
On Aug 11, 2009, at 4:56 PM, Vincent Massol wrote:
On Aug 11, 2009, at 4:17 PM, Sergiu Dumitriu wrote:
Vincent Massol wrote:
On Aug 11, 2009, at 3:14 PM, Sergiu Dumitriu wrote:
Q: Is the macro name appropriate? Do you know of a better one? Point taken: formula is better than equation. Actually, initially it was named "formula", but I didn't like it that much. Anyway, the community has spoken.
Point not taken: rendering is the right name IMO. Before xwiki- rendering as a syntax converter, rendering has a widely accepted sense as generating raster graphics. From Wikipedia: "Rendering is the process of generating an image from a model, by means of computer programs". This is what the module does, and the fact that we have another thing called "rendering" doesn't mean that we must invent new names for something standard. I'd agree to use rendering but *only* if:
* It's integrated inside the xwiki-rendering module * It's implemented as a XWiki Parser and Renderer (and thus we introduce a syntax for it)
I think it could fit well in the xwiki-rendering module. We'll need to adjust a few things (since it would be the first renderer to generate binary data) but that's a good thing.
WDYT? Well, it doesn't actually do parsing or rendering. The code is really small, and it just forwards the text to a service, which returns the binary blob.
But I don't understand why do you insist on this conflict between image rendering and text rendering? I'd really prefer that we call it xwiki-formula meaning that it contains APIs for formula manipulation (even if right now the only API we offer is one that generates an image). Same as we have xwiki- chart for manipulating charts.
Rendering has a strong connotation in xwiki land. It means http://code.xwiki.org/xwiki/bin/view/Modules/RenderingModule
+ the name is pretty long and ungainly (it seems nicer to me to keep module names as short as possible)
After more thinking I don't think it fits as a Renderer since the main idea of a Parser/Renderer is that you parse with any parser and you're able to use any renderer. This wouldn't be the case here.
Should the formula macro be in the xwiki-formula module (as a sub module for ex)? Or should it be in the rendering module? I think as we progress through componentization it should be in xwiki-formula so that we have self isolated modules that can be used as is. This would remove deps between the rendering module and xwiki-formula for ex. So as soon as a business domain materializes, everything related to that domain should find its way inside the module for that domain IMO
ok I give in :)
so I would see:
xwiki-formula/ L– xwiki-formula-renderer |_ xwiki-formula-macro
and
xwiki-chart/ |_ xwiki-chart-renderer |_ xwiki-chart-macro
wdyt?
+1 I'll move both of them now (formula and chart). -- Sergiu Dumitriu http://purl.org/net/sergiu/