On Apr 16, 2007, at 10:32 AM, Ludovic Dubost wrote: [snip]
2) You've added a new getClass API in api.XWiki: 2.1) There's no JIRA issue for this and that's important for end users 2.2) The method name is not good I think as it hides the Object.getClass() method and in any case is confusing. I would suggest getDocumentClass() 2.3) It seems to me this method should be on the Document class rather than on the XWiki class, no? The purpose of this function is to access directly to the XClass (new name) object bypassing all rights. This was need to be able to show the register page without being blocked by rights on the XWiki.XWikiUsers page. It should not be in the Document class (it already exists there (getxWikiClass) since it would be blocked by rights. I didn't thought of the getClass conflict.. We can call it getXClass. If you do it don't forget to modify registerinline.vm since there is a call there.
The reason I did not propose XClass is because even though we've agree to use this name when we talk about it, this is not a name currently used in the code and introducing a new concept in only one place in the code is, I think, a bad idea. I'd rather call it getXWikiClass() or getDocumentClass() which sounds better as more descriptive. WDYT? Thanks -Vincent