On Mon, May 30, 2016 at 1:53 PM, Thomas Mortagne <[email protected]> wrote:
On Mon, May 30, 2016 at 9:25 AM, Marius Dumitru Florea <[email protected]> wrote:
On Sat, May 28, 2016 at 4:56 PM, Vincent Massol <[email protected]> wrote:
On 28 May 2016, at 15:06, Vincent Massol <[email protected]> wrote:
On 28 May 2016, at 15:02, Thomas Mortagne <[email protected]
wrote:
On Sat, May 28, 2016 at 2:57 PM, Thomas Mortagne <[email protected]> wrote:
On Sat, May 28, 2016 at 12:08 PM, Vincent Massol <
[email protected]> wrote:
> Hi devs, > > This is a reminder for naming the contrib projects. FYI there are some guidelines here: http://contrib.xwiki.org/xwiki/bin/view/Main/#HChoosingthename > > For example for authenticators it’s authenticator-<xxx>. > > I see for example the android-authenticaitor module which should be renamed authenticator-android IMO.
It's not the same thing. This is an Android application and implementing Android authentication API, so very different from other authenticator-* which are authenticator you install in XWiki.
> > Regarding https://github.com/xwiki-contrib/oidc we need to decide what to do on 2 aspects (I’m taking the examle of oidc but this just serves as an examle for the generic discussion): > > * How do we name repositories that contain various types of sub modules? Just use the concept name as Thomas did for odidc? Or should be define a prefix such as “all-oidc” or “other-oidc” or something else. I think just the concept name is ok. WDYT?
Just the concept is enough, especially if we are talking about prefixes like "all" and "other" won't don't indicate anything.
> > * odic contains 2 submodules right now: oidc-authenticator and odic-provider. Should this be named authenticator-odic and provider-odic instead to be in sync with http://contrib.xwiki.org/xwiki/bin/view/Main/#HChoosingthename. I think so. WDYT?
I really don't think so. I prefer that submodules have consistent id naming in their own world. If we go this road then we should change the ids of most of the platform modules…
Contrib don’t have the same naming at all than xwiki github org.
For xwiki github org we have: xwiki-<module>-<submodules> For contrib github org we have: <type>-<module>-<submodules>
We can reconcile this FTM by saying that the naming rule of <type>-<module>- is only for the top level name. And submodules always follow the rule of <topmodulename>-<submodule>.
Repeating the top module name is redundant IMO, that's why I've used application-ckeditor/ui and application-filemanager/api
You are talking about the folder here while the discussion is more about the module name IMO. We could indeed start another discussion about the folder name but I don't think we should mix.
So you did prefixed all submodule with top level id too :)
Indeed, if this is about the Maven (sub-)module name then yes, I agree that we should use the naming convention we currently have in platform.
https://github.com/xwiki-contrib/application-filemanager https://github.com/xwiki-contrib/application-ckeditor
A related discussion
http://xwiki.475771.n2.nabble.com/VOTE-Remove-all-duplicated-information-fro...
Thanks, Marius
Thanks -Vincent
Thanks -Vincent
> > See also my other mail about the jira module refactorings. > > Thanks > -Vincent
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
-- Thomas Mortagne _______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs