On Nov 27, 2012, at 9:11 AM, Marius Dumitru Florea <[email protected]> wrote:
On Mon, Nov 26, 2012 at 10:44 PM, Vincent Massol <[email protected]> wrote:
Hi Sergiu,
Could you please move your document to the Draft section since it's not normal to see it in the best practices since it's not been agreed about yet?
See below
On Nov 26, 2012, at 8:35 PM, Sergiu Dumitriu <[email protected]> wrote:
On 11/26/2012 08:26 AM, Eduard Moraru wrote:
Hi Sergiu,
Great work on the translations best practices, as we really needed such a document.
Regarding the naming convention, I`m not very happy with the fact that, AFAIK, we have already [1] voted on this topic in the past. Now I know that not everybody is doing it, but I, for one, have already added a good number of translations based on this voted convention.
Ah, thanks for the link, I tried to find it but my search skills are getting rusty...
I missed the previous vote, I would have said -1 to the allCamelCasePropertyNamesInOnePart.
Also we've been using this for a long time now so please don't change it just now (that would require another vote thread) :)
It was voted but we didn't really use it..
I don't agree. I've been using it 100% of the time and others too. Anyone not using it is not following the best practice and that's pretty bad.
I agree with Sergiu that more than 2 namespaces (project and module) are needed. My vote is still +1 for Sergiu's proposal (and I was aware of the previous vote when I first reply).
There's no vote so you cannot be +1. If sergiu wants to change the current way we name transation key she should send a vote. I've moved his proposal page to http://dev.xwiki.org/xwiki/bin/view/Drafts/L10N+Conventions so that it's not confused as something established. Thanks -Vincent
Thanks, Marius
BTW it's been documented too at http://dev.xwiki.org/xwiki/bin/view/Community/DevelopmentPractices#HTranslat...
Thanks -Vincent
PS: I've not read your document yet (need to finish the release first :))
IMO, using dots to create multiple parts is better because: - it's easier to read - it provides fine-grained "namespacing", and proper namespacing is always a good thing - I have some ideas for improving the l10n process that would need this namespacing, but that's for later
For example, what does trashAttachmentsActionsCannotRestoreTooltip refer to? Splitting it into trash.attachments.actions.cannotRestore.tooltip makes it easier to understand from the first read. Same about liveTableEditorClassFieldColumnGroupLabel.
Don't worry about existing keys, as I said, there are few applications that use the same set of rules, and whatever standard we pick, we'll still have to "fix" a very large portion of keys.
-0.1 for the naming convention (Key format section), until we clear things out. +1 for the rest of the document.
Thanks, Eduard
---------- [1] http://xwiki.markmail.org/thread/6qn6peyehxr73le7
On Sat, Nov 24, 2012 at 4:55 AM, Sergiu Dumitriu <[email protected]> wrote:
Hi devs,
I've written some conventions for translation messages at http://dev.xwiki.org/xwiki/bin/view/Community/L10N+Conventions
Please provide feedback, since we terribly lack some proper rules here, and there aren't two applications that use the same conventions. Now that we have support for modular translation documents, it's a good time to clean up translations and move things out of ApplicationProperties into each application.