On Sat, May 28, 2016 at 12:08 PM, Vincent Massol <[email protected]> wrote:
Hi devs,
This is a reminder for naming the contrib projects. FYI there are some guidelines here: http://contrib.xwiki.org/xwiki/bin/view/Main/#HChoosingthename
For example for authenticators it’s authenticator-<xxx>.
I see for example the android-authenticaitor module which should be renamed authenticator-android IMO.
It's not the same thing. This is an Android application and implementing Android authentication API, so very different from other authenticator-* which are authenticator you install in XWiki.
Regarding https://github.com/xwiki-contrib/oidc we need to decide what to do on 2 aspects (I’m taking the examle of oidc but this just serves as an examle for the generic discussion):
* How do we name repositories that contain various types of sub modules? Just use the concept name as Thomas did for odidc? Or should be define a prefix such as “all-oidc” or “other-oidc” or something else. I think just the concept name is ok. WDYT?
* odic contains 2 submodules right now: oidc-authenticator and odic-provider. Should this be named authenticator-odic and provider-odic instead to be in sync with http://contrib.xwiki.org/xwiki/bin/view/Main/#HChoosingthename. I think so. WDYT?
See also my other mail about the jira module refactorings.
Thanks -Vincent
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
-- Thomas Mortagne