Vincent Massol wrote:
Hi,
I'd like to discuss the granularity we want to have for our applications. This discussion was prompted by the recent password- reset application. There are some pros and cons I think of having small applications.
Pros: - better compartimentation - different release cycle
Cons: - heaviness of release (separate XAR; etc) - different release cycle - fragmentation
My personal take is that this application should go under the administration application so that it's released together with it (it could be a sub module that is aggregated in the final XAR for the admin app.).
WDYT?
I was thinking about this myself. For me, it isn't exactly Administration, as it isn't something admins can do, that's why I created a different application. We could rename the administration application to something more generic, and which should have submodules (administration, coreClasses, passwordReset). -- Sergiu Dumitriu http://purl.org/net/sergiu/