24 Jun
2011
24 Jun
'11
7:56 a.m.
On Fri, Jun 24, 2011 at 09:51, Vincent Massol <[email protected]> wrote:
Hi,
The proposal is to make all click methods be named click*() in UI functional tests.
For example in ViewPage, instead of:
public LoginPage login() { this.loginLink.click(); return new LoginPage(); }
We would have:
public LoginPage clickLogin() { this.loginLink.click(); return new LoginPage(); }
Right now we have some methods starting with click and other not following this pattern, the idea is to homogeneize it.
WDYT?
+1 makes it a lot easier to understand what it does
Thanks -Vincent
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
-- Thomas Mortagne