On May 31, 2007, at 7:17 PM, Catalin Hritcu wrote:
Hi,
On 5/30/07, Sergiu Dumitriu <[email protected]> wrote:
On 5/29/07, Vincent Massol <[email protected]> wrote:
Some more details on this topic:
* We should have a consistent naming. Either we use XObjects/XClass and then we have to use X in front of everything: XFarm, XWiki (funny), XSpace, XDocument, etc or we agree that the namespace is enough (org.xwiki.model) to indicate that these are all XWiki classes and we drop the X. This is my preference. When we write documentation we can refer to XObjects/XClass/ to separate them from Java Objects/ Class though.
I'm for the second option, with the minor objection that I don't like having an Object class. Name collision with the most used class in the Java world. But I can deal with this inconvenience.
Sorry if I seem picky about a naming issue, but I think that naming any class Class or Object is _extremely_ confusing, not only in the discussions but also when reading code. One of the many reasons is that the java.lang package doesn't need to be imported explicitly. We already had a proposal we accepted to call them XClass and XObject: http://mail-archive.objectweb.org/xwiki-dev/2007-04/msg00073.html
I think that naming consistency should not come at the expense of clarity.
In that case they shouldn't be named XClass and XObject because this doesn't mean much. In no time we'll start calling XWiki developers X- Men... ;-) If we want to say "XWiki Class/Object" they should be named XWikiClass and XWikiObject. Same for Document, Space, Farm, etc because for example Document can be confused with DOM Document class, and we can probably find other libraries using Space, Farm, etc. Personally Class/Object doesn't bother me as it's in a separate namespace.
And if you still want naming consistency then I suggest calling them MetaClass and MetaObject, instead of perpending all the other concepts by an "X".
Yes, that's a good idea. If we wanted to go that way, we could also call them something more business oriented like Definition (for Class) and DocumentMetadata (for Object). But I'm not 100% convinced yet we need to rename them. We can think about it. For now I think the most important decision is deciding what we do with Stephane's proposition of a JCR-like model. Thanks -Vincent