I think I prefer having the internal package closer to the root (so that it's easier to spot it) but I may have made the same "error" like Guillaume and Thomas in the past. On Mon, Apr 16, 2018 at 7:28 PM, Vincent Massol <[email protected]> wrote:
Hi devs,
On Matrix/IRC, I’ve posted the following:
" * Guillaume Delhumeau: BTW your naming is strange for the internal package * for ex: package org.xwiki.notifications.preferences.internal.email; * normally we put internal just after the main package part * ie. * org.xwiki.notifications.internal.* * and org.xwiki.notifications.* for public classes * see http://dev.xwiki.org/xwiki/bin/view/Community/CodeStyle/ JavaCodeStyle/#HPackagenames * General rule is org.xwiki.(module name).internal. * I see thomas has done the same “error" for org.xwiki.job.handler.internal and org.xwiki.job.handler.internal.question . So maybe there's something to discuss/change * I guess we have a mix of both now so we should discuss it and adjust our rules if need be “
So I think we don’t have all the same rules/understanding of the definition at http://dev.xwiki.org/xwiki/bin/view/Community/CodeStyle/ JavaCodeStyle/#HPackagenames
I’d like to discuss with you to see what you prefer and adjust our rules so that it matches what we do in practice.
Any take in this?
Thanks -Vincent