Vincent Massol wrote:
On Aug 11, 2009, at 3:14 PM, Sergiu Dumitriu wrote:
Q: Is the macro name appropriate? Do you know of a better one? Point taken: formula is better than equation. Actually, initially it was named "formula", but I didn't like it that much. Anyway, the community has spoken.
Point not taken: rendering is the right name IMO. Before xwiki- rendering as a syntax converter, rendering has a widely accepted sense as generating raster graphics. From Wikipedia: "Rendering is the process of generating an image from a model, by means of computer programs". This is what the module does, and the fact that we have another thing called "rendering" doesn't mean that we must invent new names for something standard.
I'd agree to use rendering but *only* if:
* It's integrated inside the xwiki-rendering module * It's implemented as a XWiki Parser and Renderer (and thus we introduce a syntax for it)
I think it could fit well in the xwiki-rendering module. We'll need to adjust a few things (since it would be the first renderer to generate binary data) but that's a good thing.
WDYT?
Well, it doesn't actually do parsing or rendering. The code is really small, and it just forwards the text to a service, which returns the binary blob. But I don't understand why do you insist on this conflict between image rendering and text rendering? -- Sergiu Dumitriu http://purl.org/net/sergiu/