Hi devs, I noticed that we don't have a standard rule for naming component hints. So far we have: A) nestedscriptmacrovalidator -> concatenated word list B) extension.cluster -> dot separated word list C) CommentEventGeneratorListener -> CamelCase word list D) legacyEventDispatcher -> camelCase with lowercase first letter E) componentManagerBridge -> same, but getName returns the space separated version F) document-content-annotation-updater -> dash separated word list, but getName returns the CamelCase version G) register-macros-on-import -> same, but an active voice is used instead There are probably other versions as well, I just looked at EventListener implementations. So, which one should we use? Personally I'd vote for F) Second vote: For EventListeners, should the getName() always return the same thing as the component hint, or return a more user friendly description? If we're returning a different thing, then we could return a space separated description. -- Sergiu Dumitriu http://purl.org/net/sergiu/