+1 Vincent Massol wrote:
I think it would be a good idea to standardize on package naming. I've seen Jerome's commit for the new invitation manager plugin and this prompted me to send this email.
I propose the following:
* org.xwiki.<module name>.* : user public APIs * org.xwiki.<module name>.internal.* : non user public classes
- This means no "impl" package (which IMO doesn't mean much since it doesn't say if it's public or not). - This also means no "api" package (which IMO is not necessary since it should be the default and makes it more complex to use). - I also don't think we need a "spi" package since we have components.
I'm also proposing to generally follow the rules defined here: http://www.eclipse.org/articles/article.php?file=Article-API-Use/index.html (see also http://jakarta.apache.org/cactus/participating/apis.html)
Here's my +1
-- Artem Melentyev