30 Jul
2007
30 Jul
'07
10:38 a.m.
Hi XWikiers, In BaseClass there is possibility to add Boolean type field with "addBooleanField". In XwikiDocument (and then in BaseCollection), we use "getIntValue" and "setIntValue" to retrieve or set the value with 0=false and 1=true. It's very simple but I think a "get/setBooleanValue" that do the conversion would be much more readable and avoid developper to search how boolean values are really stored. Regards, Thomas Mortagne