On Wed, Nov 12, 2008 at 5:59 PM, Thomas Mortagne <[email protected]> wrote:
On Wed, Nov 12, 2008 at 5:39 PM, Vincent Massol <[email protected]> wrote:
On Nov 12, 2008, at 4:47 PM, Thomas Mortagne wrote:
Hi devs,
the xwiki-core-rendering module is growing more and more and will contain too many things and dependencies IMO.
For example I will soon commit code macro and script/groovy macros which come with big dependencies (like jython, groovy, etc.) and it would be god to not add more things in already too big core -rendering pom.xml file ;)
Now the proposal: add a xwiki-macro submodule in /platform/core and have one macro/one sub module (xwiki-macro/xwiki-macro-code, xwiki-macro/xwiki-macro-script, etc.).
+1 but with the following conditions:
1) named xwiki-macros (note the 's' since this is how we've named other modules like plugins, applications, xwiki-containers, etc)
xwiki-query and xwiki-cache does not contains "s" and xwiki-containers sub modules are named xwiki-container-* so I think there is a problem....
I would prefer follow the java package style.
2) it's released together with core, i.e. same jira project
Yes, this was implicit since it's a core sub module.
Thanks -Vincent
Jerome already created a task for it, see http://jira.xwiki.org/jira/browse/XWIKI-2823
Here is my +1
-- Thomas Mortagne
devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
-- Thomas Mortagne
-- Thomas Mortagne