Dan Miron wrote:
Hi! I've been suggested the following:
"............................................................. I'm thinking of a modification on box macro [Sat Jan 3 2009 17:02:10] … currently when you extends it you can define the class: "code" in place of "box" for exemple [Sat Jan 3 2009 17:03:34] … the problem is that it means having two different css classes: box and code when the second one is basically a copy part of the first with some more things like monospace [Sat Jan 3 2009 17:04:27] … so I propose to change the box macro to add the cutom class in place of replace box class with it: class="box code" [Sat Jan 3 2009 17:04:37] … that way you will have in css: [Sat Jan 3 2009 17:05:00] … #xwikimaincontainerinner .box { margin: 1em 0; padding: 0 1px; overflow: auto; background-color: #F1F7FF; border: 1px dotted #555555; }
#xwikimaincontainerinner .code { font-family: courier, courier new, monospace; white-space: pre; } [Sat Jan 3 2009 17:05:10] … same for other macro extending box [Sat Jan 3 2009 17:05:41] … this is way cleaner and easier to change the graphical box for all box macros [Sat Jan 3 2009 17:05:44] … WDYT ? ..................................................... " Personally, I'm +1 for that, so if anyone has a different opinion, please let me know.
+1 -- Sergiu Dumitriu http://purl.org/net/sergiu/