On Mon, Feb 11, 2008 at 3:45 PM, Sergiu Dumitriu <[email protected]> wrote:
Erin Schnabel wrote:
On Feb 10, 2008 1:03 PM, Vincent Massol <[email protected]> wrote: ...
You're touching here at XWiki core structure and it's not never a good thing to change that unless you completely understand what it means. In the same way you can delete lots of jar files in the WEB-INF/lib dir but if you do you'll find one day that when you use such and such plugin it doesn't work.
Thanks -Vincent
This is my issue with the albatross skin in general. It assumes a three panel layout that doesn't fit our corporate guidelines. (i.e. per our guidelines, the content always renders first: so you end up with the content, then the right side, then the left side). If you just brought all of the *.vm files from albatross into the templates directory, I would still be broken.. I have to go and update view, edit, inline -- any of the template documents that render the basic layout of the page.
But this is the way albatross does things, too. The panels are rendered after the content. Finch was doing it the other way around.
It still didn't fit our guidelines, which mandate what things are called, how big they are, and in what combination things can be displayed (sounds restrictive, I know, but things are very consistent, which was the intent). So, I have to go through the templates, and rename the divs and ids, and strip out assumptions about which is nested/contained in what... There are assumptions, for example, that the right sidebar on edit/admin screens is rendered inside the content form... with our page layouts, that isn't the case, so things like the DocumentInfo panel don't work as expected w/o us twiddling with them (XAPANELS-14). Many of the forms (getTextArea as the method, I think) serves up the generic name/id of "content" also, which is used by our corporate internet for other reasons... so I have to go tweak the code and templates to change that to something else, too. I'll take a look @ the InterfaceExtensions page...
I have a patch (which I should submit, because I don't think I did), that allows you to specify what the default "template" directory should be-- it's a simple patch, but allowed me to make sure that under no circumstances would xwiki go looking for things in the default template directory.
So I'll take a look @ what's coming, and we'll try to be better at submitting patches, etc. as we upgrade. There was only one of me last time around, and not enough clock..
-- Sergiu Dumitriu http://purl.org/net/sergiu/
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
-- 'Waste of a good apple' -Samwise Gamgee