[xwiki-devs] [VOTE] Rule for naming configuration properties
Hi, After discussing with thomas here's what we propose: * remove the org.xwiki or com.xpn.xwiki part before the module name * use <module>.<propertyName>. Ex: rendering.linkLabelFormat * for submodules use <module>.<sunmodule>.<propertyName>. Ex: rendering.macro.velocity.filter. ** Note1: the current property for the macro velocity filter is wrongly named: macro.velocity.filter. That would need to be fixed at some point. ** Note2: the configs in xwiki-rendering-xwiki module should be named rendering.xwiki.linkLabelFormat. We'll need to fix this at some point or rename that module to some other name. Or find a sub rule to handle this case. * use camelcase for the property name itself. ex: linkLabelFormat Here's my +1 Thanks -Vincent
On Sat, Aug 8, 2009 at 21:39, Vincent Massol<[email protected]> wrote:
Hi,
After discussing with thomas here's what we propose:
* remove the org.xwiki or com.xpn.xwiki part before the module name * use <module>.<propertyName>. Ex: rendering.linkLabelFormat * for submodules use <module>.<sunmodule>.<propertyName>. Ex: rendering.macro.velocity.filter. ** Note1: the current property for the macro velocity filter is wrongly named: macro.velocity.filter. That would need to be fixed at some point. ** Note2: the configs in xwiki-rendering-xwiki module should be named rendering.xwiki.linkLabelFormat. We'll need to fix this at some point or rename that module to some other name. Or find a sub rule to handle this case. * use camelcase for the property name itself. ex: linkLabelFormat
Here's my +1
+1
Thanks -Vincent
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
-- Thomas Mortagne
On Sun, Aug 9, 2009 at 1:09 AM, Vincent Massol <[email protected]> wrote:
Hi,
After discussing with thomas here's what we propose:
* remove the org.xwiki or com.xpn.xwiki part before the module name * use <module>.<propertyName>. Ex: rendering.linkLabelFormat * for submodules use <module>.<sunmodule>.<propertyName>. Ex: rendering.macro.velocity.filter. ** Note1: the current property for the macro velocity filter is wrongly named: macro.velocity.filter. That would need to be fixed at some point. ** Note2: the configs in xwiki-rendering-xwiki module should be named rendering.xwiki.linkLabelFormat. We'll need to fix this at some point or rename that module to some other name. Or find a sub rule to handle this case. * use camelcase for the property name itself. ex: linkLabelFormat
Here's my +1
+1
Thanks -Vincent
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
participants (3)
-
Asiri Rathnayake -
Thomas Mortagne -
Vincent Massol