Hi, After discussing with thomas here's what we propose: * remove the org.xwiki or com.xpn.xwiki part before the module name * use <module>.<propertyName>. Ex: rendering.linkLabelFormat * for submodules use <module>.<sunmodule>.<propertyName>. Ex: rendering.macro.velocity.filter. ** Note1: the current property for the macro velocity filter is wrongly named: macro.velocity.filter. That would need to be fixed at some point. ** Note2: the configs in xwiki-rendering-xwiki module should be named rendering.xwiki.linkLabelFormat. We'll need to fix this at some point or rename that module to some other name. Or find a sub rule to handle this case. * use camelcase for the property name itself. ex: linkLabelFormat Here's my +1 Thanks -Vincent