[xwiki-devs] [Proposal] Always use Class for ComponentManager.lookup() instead of string
Hi, Thomas and I would like to propose using a Class to look up components when using the ComponentManager interface. Rationale: * This removes the need for having public static final ROLE fields in interfaces and prevents duplication with annotation WDYT? I'll do it in a few hours, let me know if you don't agree. Thanks -Vincent
Vincent Massol wrote:
Hi,
Thomas and I would like to propose using a Class to look up components when using the ComponentManager interface.
Rationale: * This removes the need for having public static final ROLE fields in interfaces and prevents duplication with annotation
WDYT?
I'll do it in a few hours, let me know if you don't agree.
Do you intend to completely remove the lookup-by-string method? -- Sergiu Dumitriu http://purl.org/net/sergiu/
On Mar 27, 2009, at 5:54 PM, Sergiu Dumitriu wrote:
Vincent Massol wrote:
Hi,
Thomas and I would like to propose using a Class to look up components when using the ComponentManager interface.
Rationale: * This removes the need for having public static final ROLE fields in interfaces and prevents duplication with annotation
WDYT?
I'll do it in a few hours, let me know if you don't agree.
Do you intend to completely remove the lookup-by-string method?
yes. I don't see any use case and we can add it back if we ever require it. The idea is to have something clean and unambiguous (i.e. only one way of doing it). Thanks -Vincent
Vincent Massol wrote:
Hi,
Thomas and I would like to propose using a Class to look up components when using the ComponentManager interface.
Rationale: * This removes the need for having public static final ROLE fields in interfaces and prevents duplication with annotation
+1 +1 also for removing ROLE members. -- Sergiu Dumitriu http://purl.org/net/sergiu/
participants (2)
-
Sergiu Dumitriu -
Vincent Massol