Re: [xwiki-devs] [xwiki-notifications] r11992 - in platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store: hibernate/query jcr/query query
On Aug 23, 2008, at 1:07 AM, amelentev (SVN) wrote:
Author: amelentev Date: 2008-08-23 01:07:59 +0200 (Sat, 23 Aug 2008) New Revision: 11992
Added: platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryException.java platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryExecutor.java platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryImpl.java
I really don't like to have Impl in class names. I'd really like that we define it as a rule not to use them. All or classes are implementations anywyay... I think it's also important it ends with Query since all queries should do that. I can propose: - DefaultQuery - BasicQuery - BaseQuery Thanks -Vincent PS: Haven't reviewed the commit, just this that jumped in front of my eyes. If we're ok with it I'll put it in our best practices guide on dev.xwiki.org [snip}
On Sat, Aug 23, 2008 at 8:51 AM, Vincent Massol <[email protected]> wrote:
On Aug 23, 2008, at 1:07 AM, amelentev (SVN) wrote:
Author: amelentev Date: 2008-08-23 01:07:59 +0200 (Sat, 23 Aug 2008) New Revision: 11992
Added: platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryException.java platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryExecutor.java platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryImpl.java
I really don't like to have Impl in class names. I'd really like that we define it as a rule not to use them. All or classes are implementations anywyay... I think it's also important it ends with Query since all queries should do that.
I can propose: - DefaultQuery - BasicQuery - BaseQuery
Thanks -Vincent
PS: Haven't reviewed the commit, just this that jumped in front of my eyes. If we're ok with it I'll put it in our best practices guide on dev.xwiki.org
[snip}
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
Don't like QueryImpl too, it should be DefaultQuery if I understood well what changed. -- Thomas Mortagne
Vincent Massol wrote:
On Aug 23, 2008, at 1:07 AM, amelentev (SVN) wrote:
Author: amelentev Date: 2008-08-23 01:07:59 +0200 (Sat, 23 Aug 2008) New Revision: 11992
Added: platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryException.java platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryExecutor.java platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryImpl.java
I really don't like to have Impl in class names. I'd really like that we define it as a rule not to use them. All or classes are implementations anywyay... I think it's also important it ends with Query since all queries should do that.
I can propose: - DefaultQuery - BasicQuery - BaseQuery
Ok. Agreed. Renamed to DefaultQuery.
PS: Haven't reviewed the commit, just this that jumped in front of my eyes. If we're ok with it I'll put it in our best practices guide on dev.xwiki.org
+1 -- Artem Melentyev
Hi everyone, See http://dev.xwiki.org/xwiki/bin/view/Community/CodeStyle#HClass2FInterfacenam... Please let me know if you have any remark/issue with these naming rules. Thanks -Vincent On Aug 23, 2008, at 7:29 PM, Artem Melentyev wrote: [snip]
Vincent Massol wrote:
On Aug 23, 2008, at 1:07 AM, amelentev (SVN) wrote:
Author: amelentev Date: 2008-08-23 01:07:59 +0200 (Sat, 23 Aug 2008) New Revision: 11992
Added: platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryException.java platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryExecutor.java platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryImpl.java
I really don't like to have Impl in class names. I'd really like that we define it as a rule not to use them. All or classes are implementations anywyay... I think it's also important it ends with Query since all queries should do that.
I can propose: - DefaultQuery - BasicQuery - BaseQuery
Ok. Agreed. Renamed to DefaultQuery.
PS: Haven't reviewed the commit, just this that jumped in front of my eyes. If we're ok with it I'll put it in our best practices guide on dev.xwiki.org
+1
-- Artem Melentyev
participants (3)
-
Artem Melentyev -
Thomas Mortagne -
Vincent Massol