On Aug 23, 2008, at 1:07 AM, amelentev (SVN) wrote:
Author: amelentev Date: 2008-08-23 01:07:59 +0200 (Sat, 23 Aug 2008) New Revision: 11992
Added: platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryException.java platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryExecutor.java platform/core/trunk/xwiki-core/src/main/java/com/xpn/xwiki/store/ query/QueryImpl.java
I really don't like to have Impl in class names. I'd really like that we define it as a rule not to use them. All or classes are implementations anywyay... I think it's also important it ends with Query since all queries should do that. I can propose: - DefaultQuery - BasicQuery - BaseQuery Thanks -Vincent PS: Haven't reviewed the commit, just this that jumped in front of my eyes. If we're ok with it I'll put it in our best practices guide on dev.xwiki.org [snip}