On Feb 23, 2010, at 12:48 PM, stefan bachert wrote:
Hi Vincent,
Technical you are surely totally right in the context of xwiki But try to see that stuff from an users point of view, not from a developers one. An user want to use xwiki not to analyse it.
End users should use the wysiwyg editor and the add macro dialog box from there (which has a description).
Look what the german wikipedia thinks about wiki syntax. No macros at all. http://de.wikipedia.org/wiki/Hilfe:Textgestaltung
And the french version, discusses something which looks like "xwiki macros" but they arent. http://fr.wikipedia.org/wiki/Aide:Syntaxe
Almost all wikis have the notion of macros (sometimes called extensions or plugin too) so this is no different from any other wiki.
There is no common sense what "Wiki syntax" means. So a better term would be helpful. However, it is not easy to find something better, all I am thinking of are rather a sentence than a word.
Sure, we couldn't find a better name to explain that the wiki syntax is evaluated or not. I initially wanted wikiSyntax=true|false but in order to have a short and concise name we agreed on "wiki". Note that we wouldn't be able to change it in XWiki syntax 2.0 (since it would break backward compat). The only window of opportunity to change it would be XWiki Syntax 2.1. Thanks -Vincent
Stefan Bachert
________________________________ Von: Vincent Massol <[email protected]> An: XWiki Users <[email protected]> Gesendet: Dienstag, den 23. Februar 2010, 11:43:49 Uhr Betreff: Re: [xwiki-users] Macro in html-macro
On Feb 23, 2010, at 11:31 AM, Stefan Bachert wrote:
Hi,
Ok, I see it now, too.
However, the attribute name "wiki" is very misleading.
It's wiki as in wiki syntax. Macros **are** wiki syntax, otherwise you'd never be able to use macros when you write wiki syntax!
-Vincent
I still get no link for "wiki syntax" to "macro". Maybe with internal knowledge this may brighten up.
Stefan Bachert
________________________________ Von: vmassol [via XWiki] <[email protected]> An: Stefan Bachert <[email protected]> Gesendet: Dienstag, den 23. Februar 2010, 11:17:17 Uhr Betreff: Re: Macro in html-macro
On Feb 23, 2010, at 11:09 AM, Stefan Bachert wrote:
Hi,
I figured it out now.
{{html wiki=true}} {{warning}}Warning{{/warning}} {{/html}}
setting wiki=true will enable included macros, too. This is somewhat crude and not documented
How can you say it's not documented? http://code.xwiki.org/xwiki/bin/view/Macros/HTMLMacro
Thanks -Vincent