[xwiki-users] sources filename, why that redundancy ?
I am not XWiki developer and hardly ever would be. Even if i have my favorite mysfeatures. Also here are script-making and script-using guys. So i don't think this question would be complete off-topic. === It seems that XWiki was never tested on Windows as none of developers had it. It seems that XWiki GitHub just cannot be cloned to Windows now. And i don't know if can be compiled there (hopefully JVM can overcome it, but who knows) But what i noticed again, is that hugely redundant file naming xwiki-platform-core/xwiki-platform-classloader/xwiki-platfor m-classloader-protocols/xwiki-platform-classloader-protocol-attachmentjar/src/te st/java/org/xwiki/classloader/internal/protocol/attachmentjar/AttachmentURLStrea mHandlerTest.java Why that repeating time and gain, like if you use flat filesystem rather than tree ? It looks like calling an object org.org-xwiki.org-xwiki-classloader.org-xwiki-classloader-internal.org-xwiki-classloader-internal-protocol.org-xwiki-classloader-internal-protocol-attachmentjar.org-xwiki-classloader-internal-protocol-attachmentjar-AttachmentURLStreamHandlerTest Nonsense ? Truly so. Yet on file system level Java developers usually do it, not only XWiki but many teams. Why ? Aren't directories given to suppress such redundancy ? Not only that give overly long unobservable paths, it also disables some programs on Windows. I heard that git has internal 4KB file path length limitations. I wonder what UNIX guys would say about sanity if one day they would try to download from Windows file with name about 16KB long... -- View this message in context: http://xwiki.475771.n2.nabble.com/sources-filename-why-that-redundancy-tp758... Sent from the XWiki- Users mailing list archive at Nabble.com.
On Thu, Jul 19, 2012 at 10:48 AM, Arioch <[email protected]> wrote:
I am not XWiki developer and hardly ever would be. Even if i have my favorite mysfeatures. Also here are script-making and script-using guys. So i don't think this question would be complete off-topic.
===
It seems that XWiki was never tested on Windows as none of developers had it. It seems that XWiki GitHub just cannot be cloned to Windows now.
And i don't know if can be compiled there (hopefully JVM can overcome it, but who knows)
But what i noticed again, is that hugely redundant file naming
xwiki-platform-core/xwiki-platform-classloader/xwiki-platfor m-classloader-protocols/xwiki-platform-classloader-protocol-attachmentjar/src/te st/java/org/xwiki/classloader/internal/protocol/attachmentjar/AttachmentURLStrea mHandlerTest.java
Why that repeating time and gain, like if you use flat filesystem rather than tree ?
It's a naming convention we agreed on: the maven module folder name should be the same as the maven module artifact ID. Thanks, Marius
It looks like calling an object org.org-xwiki.org-xwiki-classloader.org-xwiki-classloader-internal.org-xwiki-classloader-internal-protocol.org-xwiki-classloader-internal-protocol-attachmentjar.org-xwiki-classloader-internal-protocol-attachmentjar-AttachmentURLStreamHandlerTest
Nonsense ? Truly so. Yet on file system level Java developers usually do it, not only XWiki but many teams. Why ? Aren't directories given to suppress such redundancy ?
Not only that give overly long unobservable paths, it also disables some programs on Windows.
I heard that git has internal 4KB file path length limitations. I wonder what UNIX guys would say about sanity if one day they would try to download from Windows file with name about 16KB long...
-- View this message in context: http://xwiki.475771.n2.nabble.com/sources-filename-why-that-redundancy-tp758... Sent from the XWiki- Users mailing list archive at Nabble.com. _______________________________________________ users mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/users
Marius Dumitru Florea [via XWiki] <[email protected]> писал(а) в своём письме Mon, 30 Jul 2012 19:29:34 +0400:
But what i noticed again, is that hugely redundant file naming xwiki-platform-core/xwiki-platform-classloader/xwiki-platfor m-classloader-protocols/xwiki-platform-classloader-protocol-attachmentjar/src/te st/java/org/xwiki/classloader/internal/protocol/attachmentjar/AttachmentURLStrea mHandlerTest.javaWhy that repeating time and gain, like if you use flat filesystem ratherthan tree ? It's a naming convention we agreed on: the maven module folder name should be the same as the maven module artifact ID.
Well, if u chosen to keep all the genealogy in the folder name, modellign after flat 1D maven list, then folder structure can be kept flat too. Call it Windows limitations or Git/Win lack of intelligency, yet you casted aside all potential Windows-based developers. -- Написано в почтовом клиенте браузера Opera: http://www.opera.com/mail/ -- View this message in context: http://xwiki.475771.n2.nabble.com/sources-filename-why-that-redundancy-tp758... Sent from the XWiki- Users mailing list archive at Nabble.com.
On 07/30/2012 02:50 PM, Arioch wrote:
Marius Dumitru Florea [via XWiki] <[email protected]> писал(а) в своём письме Mon, 30 Jul 2012 19:29:34 +0400:
But what i noticed again, is that hugely redundant file naming xwiki-platform-core/xwiki-platform-classloader/xwiki-platfor m-classloader-protocols/xwiki-platform-classloader-protocol-attachmentjar/src/te st/java/org/xwiki/classloader/internal/protocol/attachmentjar/AttachmentURLStrea mHandlerTest.javaWhy that repeating time and gain, like if you use flat filesystem ratherthan tree ? It's a naming convention we agreed on: the maven module folder name should be the same as the maven module artifact ID.
Well, if u chosen to keep all the genealogy in the folder name, modellign after flat 1D maven list, then folder structure can be kept flat too.
Call it Windows limitations or Git/Win lack of intelligency, yet you casted aside all potential Windows-based developers.
We are aware of the problem and we do plan on fixing it. But such a change will break lots of things, like existing pull request, forks, local checkouts... It's not easy to change the whole layout of a project that's widely cloned. -- Sergiu Dumitriu http://purl.org/net/sergiu/
participants (3)
-
Arioch -
Marius Dumitru Florea -
Sergiu Dumitriu