On 07/30/2012 02:50 PM, Arioch wrote:
Marius Dumitru Florea [via XWiki] <[email protected]> писал(а) в своём письме Mon, 30 Jul 2012 19:29:34 +0400:
But what i noticed again, is that hugely redundant file naming xwiki-platform-core/xwiki-platform-classloader/xwiki-platfor m-classloader-protocols/xwiki-platform-classloader-protocol-attachmentjar/src/te st/java/org/xwiki/classloader/internal/protocol/attachmentjar/AttachmentURLStrea mHandlerTest.javaWhy that repeating time and gain, like if you use flat filesystem ratherthan tree ? It's a naming convention we agreed on: the maven module folder name should be the same as the maven module artifact ID.
Well, if u chosen to keep all the genealogy in the folder name, modellign after flat 1D maven list, then folder structure can be kept flat too.
Call it Windows limitations or Git/Win lack of intelligency, yet you casted aside all potential Windows-based developers.
We are aware of the problem and we do plan on fixing it. But such a change will break lots of things, like existing pull request, forks, local checkouts... It's not easy to change the whole layout of a project that's widely cloned. -- Sergiu Dumitriu http://purl.org/net/sergiu/