lists.xwiki.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

notifications

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
[email protected]

August 2026

  • 1 participants
  • 2088 discussions
[xwiki-contrib/confluence] af06dc: [maven-release-plugin] prepare release confluence-...
by XWiki Notifications 10 Aug '26

10 Aug '26
Branch: refs/heads/master Home: https://github.com/xwiki-contrib/confluence Commit: af06dca7ab5fc39a907ca21e9f1d520da21b68a4 https://github.com/xwiki-contrib/confluence/commit/af06dca7ab5fc39a907ca21e… Author: Raphaël Jakse <raphael.jakse(a)xwiki.com> Date: 2026-08-10 (Mon, 10 Aug 2026) Changed paths: M confluence-resolvers/pom.xml M confluence-resource-reference-type-parsers/pom.xml M confluence-syntax-confluence/pom.xml M confluence-syntax-confluence10override/pom.xml M confluence-syntax-xhtml/pom.xml M confluence-url-mapping-scroll-viewport/pom.xml M confluence-url-mapping/pom.xml M confluence-xml/pom.xml M pom.xml Log Message: ----------- [maven-release-plugin] prepare release confluence-9.96.0 To unsubscribe from these emails, change your notification settings at https://github.com/xwiki-contrib/confluence/settings/notifications
1 0
0 0
[xwiki/xwiki-dev-llm] 4308ce: [Misc] Document the S117 naming rule in the SonarQ...
by XWiki Notifications 10 Aug '26

10 Aug '26
Branch: refs/heads/claude/cool-tesla-7ki1p0 Home: https://github.com/xwiki/xwiki-dev-llm Commit: 4308cec2d397865784060b8897efd7d93abf49a1 https://github.com/xwiki/xwiki-dev-llm/commit/4308cec2d397865784060b8897efd… Author: Vincent Massol <vincent(a)massol.net> Date: 2026-08-10 (Mon, 10 Aug 2026) Changed paths: M .claude-plugin/marketplace.json M kimi.plugin.json M opencode.jsonc M xwiki/.claude-plugin/plugin.json M xwiki/okf/sonarqube/index.md M xwiki/okf/sonarqube/syntax-rules.md Log Message: ----------- [Misc] Document the S117 naming rule in the SonarQube OKF * Add an S117 section to the syntax-rules family: locals vs parameters as the safe/unsure split, the `this.<name>` shadowing trap and the new-name-unused assertion. * Note in the denylist why the neighbouring S1117 is not worth fixing, so the two rules are not confused. * Bump the plugin version to 1.0.17. Co-Authored-By: Vincent Massol <vincent(a)massol.net> To unsubscribe from these emails, change your notification settings at https://github.com/xwiki/xwiki-dev-llm/settings/notifications
1 0
0 0
[xwiki/xwiki-commons] 0fe5e9: [Misc] Rename local variables not matching the nam...
by XWiki Notifications 10 Aug '26

10 Aug '26
Branch: refs/heads/claude/nifty-bell-7ki1p0 Home: https://github.com/xwiki/xwiki-commons Commit: 0fe5e94be576f3c093b8fca928f1e1e2ef20001a https://github.com/xwiki/xwiki-commons/commit/0fe5e94be576f3c093b8fca928f1e… Author: Vincent Massol <vincent(a)massol.net> Date: 2026-08-10 (Mon, 10 Aug 2026) Changed paths: M xwiki-commons-core/xwiki-commons-extension/xwiki-commons-extension-api/src/test/java/org/xwiki/extension/job/internal/InstallJobTest.java Log Message: ----------- [Misc] Rename local variables not matching the naming convention (SonarQube) * Fix 2 java:S117 issues in InstallJobTest: two locals were named as if they were constants. Co-Authored-By: Vincent Massol <vincent(a)massol.net> To unsubscribe from these emails, change your notification settings at https://github.com/xwiki/xwiki-commons/settings/notifications
1 0
0 0
[xwiki/xwiki-platform] 5fb25b: [Misc] Rename method parameters not matching the n...
by XWiki Notifications 10 Aug '26

10 Aug '26
Branch: refs/heads/claude/clever-feynman-7ki1p0-s117-params Home: https://github.com/xwiki/xwiki-platform Commit: 5fb25bb9058ee4bedd5453c13274df5072a2ec72 https://github.com/xwiki/xwiki-platform/commit/5fb25bb9058ee4bedd5453c13274… Author: Vincent Massol <vincent(a)massol.net> Date: 2026-08-10 (Mon, 10 Aug 2026) Changed paths: M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/XWiki.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/XWikiContext.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/api/XWiki.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/doc/XWikiAttachment.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/objects/BaseCollection.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/plugin/packaging/DocumentInfo.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/plugin/packaging/Package.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/plugin/packaging/PackageAPI.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/web/Utils.java Log Message: ----------- [Misc] Rename method parameters not matching the naming convention (SonarQube) * Fix 17 java:S117 issues: method parameters named with underscores or a leading uppercase letter are renamed to camelCase. * Parameter names only; the identically-named fields these parameters used to shadow are left untouched, so no signature, API or behaviour changes. Co-Authored-By: Vincent Massol <vincent(a)massol.net> To unsubscribe from these emails, change your notification settings at https://github.com/xwiki/xwiki-platform/settings/notifications
1 0
0 0
[xwiki/xwiki-platform] b2ff60: [Misc] Rename local variables not matching the nam...
by XWiki Notifications 10 Aug '26

10 Aug '26
Branch: refs/heads/claude/clever-feynman-7ki1p0 Home: https://github.com/xwiki/xwiki-platform Commit: b2ff60256eadd3ab5a28a9ffa90c386eba3336aa https://github.com/xwiki/xwiki-platform/commit/b2ff60256eadd3ab5a28a9ffa90c… Author: Vincent Massol <vincent(a)massol.net> Date: 2026-08-10 (Mon, 10 Aug 2026) Changed paths: M xwiki-platform-core/xwiki-platform-notifications/xwiki-platform-notifications-filters/xwiki-platform-notifications-filters-api/src/test/java/org/xwiki/notifications/filters/internal/scope/ScopeNotificationFilterTest.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/objects/classes/BaseClass.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/objects/classes/BooleanClass.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/store/XWikiHibernateStore.java M xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/user/impl/xwiki/XWikiRightServiceImpl.java Log Message: ----------- [Misc] Rename local variables not matching the naming convention (SonarQube) * Fix 28 java:S117 issues: local variables named with underscores, a leading uppercase letter or a non-ASCII letter are renamed to camelCase. * Pure renames, scoped to the declaring method; no behaviour change. Co-Authored-By: Vincent Massol <vincent(a)massol.net> To unsubscribe from these emails, change your notification settings at https://github.com/xwiki/xwiki-platform/settings/notifications
1 0
0 0
[xwiki/xwiki-dev-llm] 2e27fe: [Misc] Record the two S5778 shapes a naive hoist g...
by XWiki Notifications 09 Aug '26

09 Aug '26
Branch: refs/heads/claude/cool-tesla-hm2vpc Home: https://github.com/xwiki/xwiki-dev-llm Commit: 2e27fe3bff5e67fe7d12b1ea90df6f9e9aef5f40 https://github.com/xwiki/xwiki-dev-llm/commit/2e27fe3bff5e67fe7d12b1ea90df6… Author: Vincent Massol <vincent(a)massol.net> Date: 2026-08-09 (Sun, 09 Aug 2026) Changed paths: M .claude-plugin/marketplace.json M kimi.plugin.json M opencode.jsonc M xwiki/.claude-plugin/plugin.json M xwiki/okf/sonarqube/test-code-rules.md Log Message: ----------- [Misc] Record the two S5778 shapes a naive hoist gets wrong * The outer call can be the thrower while its arguments are the fixtures, so "hoist the nested invocation" must not become "hoist the whole lambda body". * A block-bodied assertThrows lambda is a fix, not a drop. Co-Authored-By: Vincent Massol <vincent(a)massol.net> To unsubscribe from these emails, change your notification settings at https://github.com/xwiki/xwiki-dev-llm/settings/notifications
1 0
0 0
[xwiki/xwiki-platform] 4cbfa0: [Misc] Refactor assertThrows lambdas holding more ...
by XWiki Notifications 09 Aug '26

09 Aug '26
Branch: refs/heads/claude/clever-feynman-hm2vpc Home: https://github.com/xwiki/xwiki-platform Commit: 4cbfa092394bc1822a2ac7677432307d05b922cd https://github.com/xwiki/xwiki-platform/commit/4cbfa092394bc1822a2ac7677432… Author: Vincent Massol <vincent(a)massol.net> Date: 2026-08-09 (Sun, 09 Aug 2026) Changed paths: M xwiki-platform-core/xwiki-platform-component/xwiki-platform-component-multi/src/test/java/org/xwiki/component/internal/ContextComponentManagerTest.java M xwiki-platform-core/xwiki-platform-eventstream/xwiki-platform-eventstream-api/src/test/java/org/xwiki/eventstream/EventGroupTest.java M xwiki-platform-core/xwiki-platform-mail/xwiki-platform-mail-send/xwiki-platform-mail-send-api/src/test/java/org/xwiki/mail/ExtendedMimeMessageTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/internal/reference/DefaultReferenceEntityReferenceResolverTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/internal/reference/ExplicitReferenceEntityReferenceResolverTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/internal/reference/ExplicitStringEntityReferenceResolverTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/AttachmentReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/BlockReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/ClassPropertyReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/DocumentReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/EntityReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/ObjectPropertyReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/ObjectReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/PageAttachmentReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/PageClassPropertyReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/PageObjectPropertyReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/PageObjectReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/PageReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/SpaceReferenceTest.java M xwiki-platform-core/xwiki-platform-model/xwiki-platform-model-api/src/test/java/org/xwiki/model/reference/WikiReferenceTest.java M xwiki-platform-core/xwiki-platform-oldcore/src/test/java/com/xpn/xwiki/doc/XWikiAttachmentTest.java M xwiki-platform-core/xwiki-platform-rendering/xwiki-platform-rendering-signature/src/test/java/org/xwiki/rendering/signature/internal/MacroBlockDumperTest.java M xwiki-platform-core/xwiki-platform-rendering/xwiki-platform-rendering-signature/src/test/java/org/xwiki/rendering/signature/internal/MacroBlockSignatureGeneratorTest.java M xwiki-platform-core/xwiki-platform-rendering/xwiki-platform-rendering-signature/src/test/java/org/xwiki/rendering/signature/internal/MacroBlockSignatureVerifierTest.java M xwiki-platform-core/xwiki-platform-rendering/xwiki-platform-rendering-xwiki/src/test/java/org/xwiki/rendering/script/RenderingScriptServiceTest.java M xwiki-platform-core/xwiki-platform-store/xwiki-platform-store-merge/xwiki-platform-store-merge-api/src/test/java/org/xwiki/store/merge/MergeDocumentResultTest.java M xwiki-platform-core/xwiki-platform-store/xwiki-platform-store-transaction/src/test/java/org/xwiki/store/TransactionRunnableTest.java M xwiki-platform-core/xwiki-platform-user/xwiki-platform-user-default/src/test/java/org/xwiki/user/internal/DefaultUserPropertiesResolverTest.java M xwiki-platform-core/xwiki-platform-vfs/xwiki-platform-vfs-api/src/test/java/org/xwiki/vfs/internal/script/PathConverterTest.java Log Message: ----------- [Misc] Refactor assertThrows lambdas holding more than one throwing call (SonarQube) * Fix 51 java:S5778 issues by hoisting the non-throwing invocation (an EntityReference, a WordBlock, a converter type, ...) into a local declared before the assertThrows call, so the lambda holds only the call that is expected to throw. * Turn the five block-bodied lambdas into expression lambdas at the same time, since they were only wrapping a setup statement. Co-Authored-By: Vincent Massol <vincent(a)massol.net> To unsubscribe from these emails, change your notification settings at https://github.com/xwiki/xwiki-platform/settings/notifications
1 0
0 0
[[email protected]][Issue] Updates for XWIKI-24675: Add an option for the pdf export to allow a user that has hidden pages enabled to exclude them from the exported result
by XWiki Notifications 08 Aug '26

08 Aug '26
1 0
0 0
[[email protected]][Issue] Updates for XWIKI-24674: Exclude WebPreferences pages from the PDF export of page and children, regardless of the preferences of the current user
by XWiki Notifications 08 Aug '26

08 Aug '26
1 0
0 0
[[email protected]][Issue] Updates for FILEMAN-126: File manager is creating documents with no language for the uploaded files
by XWiki Notifications 08 Aug '26

08 Aug '26
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 150
  • 151
  • 152
  • 153
  • 154
  • 155
  • 156
  • ...
  • 209
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.