On 15 avr. 08, at 12:01, Vincent Massol wrote:
Why not create:
xwiki-platform-core/xwiki-xmlrpc/ |_ xwiki-xmlrpc-model/ |_ xwiki-xmlrpc-client/
About splitting into model&client, we discussed that with Fabio and since the client is only one java class we agreed that it was a bit overkill to have a module for it. Wdyt ?
Sure that's fine with me to create a single module for now. Just not sure how to name it then. xwiki-xmlrpc-model?
Imho the name should clearly suggest to a potential user who wants to interact with xwiki via xmlrpc that this is the "thing" it should download/use. To me xwiki-xmlrpc-model doesn't seem to convey that idea too much. Simply "xwiki-xmlrpc" seems to be a better name to me, though having xwiki-platform-core/xwiki-xmlrpc/xwiki-xmlrpc is a bit weird/confusing. Or as Vincent suggested, having xwiki-xmlrpc-model and xwiki-xmlrpc- client is fine as well (even though xwiki-xmlrpc-client would be a module with only 1 class) and maybe it's the right solution to the dilemma :) My 2 cents. Cheers, Fabio