On Sep 23, 2010, at 12:30 PM, Marius Dumitru Florea wrote:
Hi devs,
Vincent suggested that I should rename xwiki-officeimporter and xwiki-officepreview to xwiki-office-importer and xwiki-office-preview respectively. The rules are:
* module name starts with "xwiki" * separate words with - (dash) (e.g. xwiki-shared-tests) * prefer short names (fewer words) (xwiki-csrf instead of xwiki-csrftoken) * avoid generic words like "service", "manger" (e.g. xwiki-patch instead of xwiki-patch-service)
I'm +1 for these rules. If you agree I'll rename the office modules.
+1 for now. In the future we'll need to define the mapping between directory name and Maven artifact id (i.e. whether we want to have directory name = artifact id - the "xwiki-" prefix, or have directory name = artifact id, for example). Thanks -Vincent