[xwiki-devs] [Vote] Use - (dash) to separate words in module name
Hi devs, Vincent suggested that I should rename xwiki-officeimporter and xwiki-officepreview to xwiki-office-importer and xwiki-office-preview respectively. The rules are: * module name starts with "xwiki" * separate words with - (dash) (e.g. xwiki-shared-tests) * prefer short names (fewer words) (xwiki-csrf instead of xwiki-csrftoken) * avoid generic words like "service", "manger" (e.g. xwiki-patch instead of xwiki-patch-service) I'm +1 for these rules. If you agree I'll rename the office modules. Thanks, Marius
+1, JV. On Thu, Sep 23, 2010 at 12:30 PM, Marius Dumitru Florea <[email protected]> wrote:
Hi devs,
Vincent suggested that I should rename xwiki-officeimporter and xwiki-officepreview to xwiki-office-importer and xwiki-office-preview respectively. The rules are:
* module name starts with "xwiki" * separate words with - (dash) (e.g. xwiki-shared-tests) * prefer short names (fewer words) (xwiki-csrf instead of xwiki-csrftoken) * avoid generic words like "service", "manger" (e.g. xwiki-patch instead of xwiki-patch-service)
I'm +1 for these rules. If you agree I'll rename the office modules.
Thanks, Marius _______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
On Sep 23, 2010, at 12:30 PM, Marius Dumitru Florea wrote:
Hi devs,
Vincent suggested that I should rename xwiki-officeimporter and xwiki-officepreview to xwiki-office-importer and xwiki-office-preview respectively. The rules are:
* module name starts with "xwiki" * separate words with - (dash) (e.g. xwiki-shared-tests) * prefer short names (fewer words) (xwiki-csrf instead of xwiki-csrftoken) * avoid generic words like "service", "manger" (e.g. xwiki-patch instead of xwiki-patch-service)
I'm +1 for these rules. If you agree I'll rename the office modules.
+1 for now. In the future we'll need to define the mapping between directory name and Maven artifact id (i.e. whether we want to have directory name = artifact id - the "xwiki-" prefix, or have directory name = artifact id, for example). Thanks -Vincent
+1 On Thu, Sep 23, 2010 at 12:30, Marius Dumitru Florea <[email protected]> wrote:
Hi devs,
Vincent suggested that I should rename xwiki-officeimporter and xwiki-officepreview to xwiki-office-importer and xwiki-office-preview respectively. The rules are:
* module name starts with "xwiki" * separate words with - (dash) (e.g. xwiki-shared-tests) * prefer short names (fewer words) (xwiki-csrf instead of xwiki-csrftoken) * avoid generic words like "service", "manger" (e.g. xwiki-patch instead of xwiki-patch-service)
I'm +1 for these rules. If you agree I'll rename the office modules.
Thanks, Marius _______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
-- Thomas Mortagne
+1 I'll rename csrftoken to stick to the rules too. Alex On 09/23/2010 12:30 PM, Marius Dumitru Florea wrote:
Hi devs,
Vincent suggested that I should rename xwiki-officeimporter and xwiki-officepreview to xwiki-office-importer and xwiki-office-preview respectively. The rules are:
* module name starts with "xwiki" * separate words with - (dash) (e.g. xwiki-shared-tests) * prefer short names (fewer words) (xwiki-csrf instead of xwiki-csrftoken) * avoid generic words like "service", "manger" (e.g. xwiki-patch instead of xwiki-patch-service)
I'm +1 for these rules. If you agree I'll rename the office modules.
Thanks, Marius _______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
Hi, Sorry for replying a bit late on this. See below On Thu, Sep 23, 2010 at 2:51 PM, Alex Busenius <[email protected]> wrote:
+1
I'll rename csrftoken to stick to the rules too.
Alex
On 09/23/2010 12:30 PM, Marius Dumitru Florea wrote:
Hi devs,
Vincent suggested that I should rename xwiki-officeimporter and xwiki-officepreview to xwiki-office-importer and xwiki-office-preview respectively. The rules are:
* module name starts with "xwiki" * separate words with - (dash) (e.g. xwiki-shared-tests) * prefer short names (fewer words) (xwiki-csrf instead of xwiki-csrftoken)
I don't think xwiki-crsf is such a good name. It's like we would call an anti-spam module "xwiki-spam". A bit weird, no ? Why not xwiki-anti-crsf ? or xwiki-crsf-prevention ? My 2 cents, Jerome.
* avoid generic words like "service", "manger" (e.g. xwiki-patch instead of xwiki-patch-service)
I'm +1 for these rules. If you agree I'll rename the office modules.
Thanks, Marius _______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
_______________________________________________ devs mailing list [email protected] http://lists.xwiki.org/mailman/listinfo/devs
participants (6)
-
Alex Busenius -
Jean-Vincent Drean -
Jerome Velociter -
Marius Dumitru Florea -
Thomas Mortagne -
Vincent Massol