Non alphanumerics and white spaces in Wiki page Names
One thing I'm planning to do, is liberate the special characters in document names. I've had too many problems not accepting accents in wiki page names, even though for european accents they are converted to non-accentued characters automatically when used in a link. The problem is that this cannot be made general because some languages have special characters that do not have a "non-special" fallback.. So I'm thinking of letting any character being chosen in Wiki page names, using the URL encoding conversion of course. Doing this is not too much a problem. One other thing is what to do with white spaces. Currently if you type [new page] the link created is newpage I've had some complaints about it because when we show page searches it shows a concatenated text string instead of a nice page name. Another problem is that it makes it very difficult to search automatically for backlinks in the database since the white space could be anywere in the database. Backlinks would be usefull for displaying and for moving pages and automatically updating links. What I propose is to now default to new%20page for this link which one exception when the page 'newpage' already exists (this treatment could be an option). This way there would be backwards compatibility. Linked with the change for non alphanumerical characters it would free page naming. What do you think ? Ludovic -- Ludovic Dubost XPertNet: http://www.xpertnet.fr/ Blog: http://www.ludovic.org/blog/ XWiki: http://www.xwiki.com Skype: ldubost AIM: nvludo Yahoo: ludovic
What I propose is to now default to new%20page
One drawback of new%20page is its bad readability comparing to other delimiters like new+page (used in an other wiki engine) or new_page when inserted as a link to emails etc... Jiri.
Actually, I can use "+" since it is allowed in the URL encoding.. Other chars like accent will be encoded, but there is not much you can do about it.. Ludovic Jiri Luzny a écrit :
What I propose is to now default to new%20page
One drawback of new%20page is its bad readability comparing to other delimiters like new+page (used in an other wiki engine) or new_page when inserted as a link to emails etc...
Jiri.
------------------------------------------------------------------------
-- You receive this message as a subscriber of the [email protected] mailing list. To unsubscribe: mailto:[email protected] For general help: mailto:[email protected]?subject=help ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
-- Ludovic Dubost XPertNet: http://www.xpertnet.fr/ Blog: http://www.ludovic.org/blog/ XWiki: http://www.xwiki.com Skype: ldubost AIM: nvludo Yahoo: ludovic
Actually, I can use "+" since it is allowed in the URL encoding..
... and "+" will be replaced by " " when shown on places as the search page? On Fri, 22 Apr 2005 10:17:28 +0200, you wrote:
Actually, I can use "+" since it is allowed in the URL encoding.. Other chars like accent will be encoded, but there is not much you can do about it..
Ludovic
Jiri Luzny a écrit :
What I propose is to now default to new%20page
One drawback of new%20page is its bad readability comparing to other delimiters like new+page (used in an other wiki engine) or new_page when inserted as a link to emails etc...
Jiri.
------------------------------------------------------------------------
-- You receive this message as a subscriber of the [email protected] mailing list. To unsubscribe: mailto:[email protected] For general help: mailto:[email protected]?subject=help ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
I don't think you even need it since you would store the white space as a white space. It's only the URL generation that actually shows it as "+" Ludovic Jiri Luzny a écrit :
Actually, I can use "+" since it is allowed in the URL encoding..
... and "+" will be replaced by " " when shown on places as the search page?
On Fri, 22 Apr 2005 10:17:28 +0200, you wrote:
Actually, I can use "+" since it is allowed in the URL encoding.. Other chars like accent will be encoded, but there is not much you can do about it..
Ludovic
Jiri Luzny a écrit :
What I propose is to now default to new%20page
One drawback of new%20page is its bad readability comparing to other delimiters like new+page (used in an other wiki engine) or new_page when inserted as a link to emails etc...
Jiri.
------------------------------------------------------------------------
-- You receive this message as a subscriber of the [email protected] mailing list. To unsubscribe: mailto:[email protected] For general help: mailto:[email protected]?subject=help ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
------------------------------------------------------------------------
-- You receive this message as a subscriber of the [email protected] mailing list. To unsubscribe: mailto:[email protected] For general help: mailto:[email protected]?subject=help ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
-- Ludovic Dubost XPertNet: http://www.xpertnet.fr/ Blog: http://www.ludovic.org/blog/ XWiki: http://www.xwiki.com Skype: ldubost AIM: nvludo Yahoo: ludovic
participants (2)
-
Jiri Luzny -
Ludovic Dubost